summaryrefslogtreecommitdiffstats
path: root/odk/settings/platform.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /odk/settings/platform.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/settings/platform.mk')
-rw-r--r--odk/settings/platform.mk72
1 files changed, 72 insertions, 0 deletions
diff --git a/odk/settings/platform.mk b/odk/settings/platform.mk
new file mode 100644
index 000000000..6980a7271
--- /dev/null
+++ b/odk/settings/platform.mk
@@ -0,0 +1,72 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+
+# Map target platform (extension cfg) and extension platform (SDK settings)
+# See:
+# http://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Target_Platform
+# odk/settings/settings.mk
+
+# only make version 3.81 or later accepts the multiple else conditions
+ifeq "$(UNOPKG_PLATFORM)" "FreeBSD_x86"
+ EXTENSION_PLATFORM=freebsd_x86
+else
+ ifeq "$(UNOPKG_PLATFORM)" "FreeBSD_x86_64"
+ EXTENSION_PLATFORM=freebsd_x86_64
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "Linux_PowerPC"
+ EXTENSION_PLATFORM=linux_powerpc
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "Linux_x86"
+ EXTENSION_PLATFORM=linux_x86
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "Linux_x86_64"
+ EXTENSION_PLATFORM=linux_x86_64
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "MacOSX_PowerPC"
+ EXTENSION_PLATFORM=macosx_powerpc
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "MacOSX_x86"
+ EXTENSION_PLATFORM=macosx_x86
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "MacOSX_x86_64"
+ EXTENSION_PLATFORM=macosx_x86_64
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "Solaris_SPARC"
+ EXTENSION_PLATFORM=solaris_sparc
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "Solaris_x86"
+ EXTENSION_PLATFORM=solaris_x86
+ else
+ ifeq "$(UNOPKG_PLATFORM)" "Windows"
+ ifeq "$(PROCTYPE)" "x86_64"
+ EXTENSION_PLATFORM=windows_x86_64
+ else
+ EXTENSION_PLATFORM=windows_x86
+ endif
+ endif
+ endif
+ endif
+ endif
+ endif
+ endif
+ endif
+ endif
+ endif
+ endif
+endif