summaryrefslogtreecommitdiffstats
path: root/sw/CppunitTest_sw_ooxmlencryption.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /sw/CppunitTest_sw_ooxmlencryption.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sw/CppunitTest_sw_ooxmlencryption.mk')
-rw-r--r--sw/CppunitTest_sw_ooxmlencryption.mk53
1 files changed, 53 insertions, 0 deletions
diff --git a/sw/CppunitTest_sw_ooxmlencryption.mk b/sw/CppunitTest_sw_ooxmlencryption.mk
new file mode 100644
index 000000000..b425b6eb8
--- /dev/null
+++ b/sw/CppunitTest_sw_ooxmlencryption.mk
@@ -0,0 +1,53 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,sw_ooxmlencryption))
+
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sw_ooxmlencryption))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sw_ooxmlencryption, \
+ sw/qa/extras/ooxmlexport/ooxmlencryption \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sw_ooxmlencryption, \
+ $(sw_ooxmlexport_libraries) \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,sw_ooxmlencryption,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_set_include,sw_ooxmlencryption,\
+ -I$(SRCDIR)/sw/inc \
+ -I$(SRCDIR)/sw/source/core/inc \
+ -I$(SRCDIR)/sw/qa/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_api,sw_ooxmlencryption,\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,sw_ooxmlencryption))
+$(eval $(call gb_CppunitTest_use_vcl,sw_ooxmlencryption))
+
+$(eval $(call gb_CppunitTest_use_rdb,sw_ooxmlencryption,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,sw_ooxmlencryption))
+
+$(eval $(call gb_CppunitTest_use_packages,sw_ooxmlencryption,\
+ oox_generated \
+))
+
+# vim: set noet sw=4 ts=4: