summaryrefslogtreecommitdiffstats
path: root/sw/CppunitTest_sw_ooxmlimport2.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /sw/CppunitTest_sw_ooxmlimport2.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sw/CppunitTest_sw_ooxmlimport2.mk')
-rw-r--r--sw/CppunitTest_sw_ooxmlimport2.mk80
1 files changed, 80 insertions, 0 deletions
diff --git a/sw/CppunitTest_sw_ooxmlimport2.mk b/sw/CppunitTest_sw_ooxmlimport2.mk
new file mode 100644
index 000000000..f47d7e358
--- /dev/null
+++ b/sw/CppunitTest_sw_ooxmlimport2.mk
@@ -0,0 +1,80 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,sw_ooxmlimport2))
+
+ifneq ($(OS),MACOSX)
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sw_ooxmlimport2))
+endif
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sw_ooxmlimport2, \
+ sw/qa/extras/ooxmlimport/ooxmlimport2 \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sw_ooxmlimport2, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sfx \
+ test \
+ unotest \
+ utl \
+ sw \
+ tl \
+ vcl \
+ svxcore \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,sw_ooxmlimport2,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_set_include,sw_ooxmlimport2,\
+ -I$(SRCDIR)/sw/inc \
+ -I$(SRCDIR)/sw/source/core/inc \
+ -I$(SRCDIR)/sw/source/uibase/inc \
+ -I$(SRCDIR)/sw/qa/inc \
+ $$(INCLUDE) \
+))
+
+ifeq ($(OS),MACOSX)
+
+$(eval $(call gb_CppunitTest_add_cxxflags,sw_ooxmlimport2,\
+ $(gb_OBJCXXFLAGS) \
+))
+
+$(eval $(call gb_CppunitTest_use_system_darwin_frameworks,sw_ooxmlimport2,\
+ AppKit \
+))
+
+endif
+
+$(eval $(call gb_CppunitTest_use_api,sw_ooxmlimport2,\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,sw_ooxmlimport2))
+$(eval $(call gb_CppunitTest_use_vcl,sw_ooxmlimport2))
+
+$(eval $(call gb_CppunitTest_use_rdb,sw_ooxmlimport2,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,sw_ooxmlimport2))
+
+# At least testTdf115094::Import (sw/qa/extras/ooxmlimport/ooxmlimport2.cxx) depends on TIFFReader
+# from Library_gie, which is loaded dynamically in vcl/source/filter/graphicfilter.cxx:
+$(call gb_CppunitTest_get_target,sw_ooxmlimport2): $(call gb_Library_get_target,gie)
+
+# vim: set noet sw=4 ts=4: