summaryrefslogtreecommitdiffstats
path: root/uitest/Module_uitest.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /uitest/Module_uitest.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'uitest/Module_uitest.mk')
-rw-r--r--uitest/Module_uitest.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/uitest/Module_uitest.mk b/uitest/Module_uitest.mk
new file mode 100644
index 000000000..bd65a088e
--- /dev/null
+++ b/uitest/Module_uitest.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,uitest))
+
+$(eval $(call gb_Module_add_uicheck_targets,uitest,\
+ UITest_calc_demo \
+ UITest_writer_demo1 \
+ UITest_writer_demo2 \
+ UITest_writer_demo3 \
+ UITest_writer_demo4 \
+ UITest_writer_demo5 \
+ UITest_writer_demo6 \
+ UITest_writer_demo7 \
+ UITest_writer_demo8 \
+ UITest_impress_demo \
+ UITest_demo_ui \
+ UITest_math_demo \
+ UITest_manual_tests \
+))