summaryrefslogtreecommitdiffstats
path: root/ure/Rdb_ure.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /ure/Rdb_ure.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ure/Rdb_ure.mk')
-rw-r--r--ure/Rdb_ure.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/ure/Rdb_ure.mk b/ure/Rdb_ure.mk
new file mode 100644
index 000000000..7a64cfb22
--- /dev/null
+++ b/ure/Rdb_ure.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Rdb_Rdb_install,ure/services,$(LIBO_URE_MISC_FOLDER)/services.rdb))
+
+$(eval $(call gb_Rdb_add_components,ure/services,\
+ binaryurp/source/binaryurp \
+ io/source/io \
+ stoc/util/bootstrap \
+ stoc/source/inspect/introspection \
+ stoc/source/invocation_adapterfactory/invocadapt \
+ stoc/source/invocation/invocation \
+ stoc/source/namingservice/namingservice \
+ stoc/source/proxy_factory/proxyfac \
+ stoc/source/corereflection/reflection \
+ stoc/util/stocservices \
+ remotebridges/source/unourl_resolver/uuresolver \
+))
+
+ifneq ($(ENABLE_JAVA),)
+$(eval $(call gb_Rdb_add_components,ure/services,\
+ stoc/source/javaloader/javaloader \
+ stoc/source/javavm/javavm \
+))
+endif
+
+# vim:set noet sw=4 ts=4: