summaryrefslogtreecommitdiffstats
path: root/external/owncloud-android-lib
diff options
context:
space:
mode:
Diffstat (limited to 'external/owncloud-android-lib')
-rw-r--r--external/owncloud-android-lib/ExternalProject_owncloud_android_lib.mk23
-rw-r--r--external/owncloud-android-lib/Makefile7
-rw-r--r--external/owncloud-android-lib/Module_owncloud-android-lib.mk17
-rw-r--r--external/owncloud-android-lib/README7
-rw-r--r--external/owncloud-android-lib/UnpackedTarball_owncloud_android_lib.mk16
-rw-r--r--external/owncloud-android-lib/build.gradle57
6 files changed, 127 insertions, 0 deletions
diff --git a/external/owncloud-android-lib/ExternalProject_owncloud_android_lib.mk b/external/owncloud-android-lib/ExternalProject_owncloud_android_lib.mk
new file mode 100644
index 000000000..149becee9
--- /dev/null
+++ b/external/owncloud-android-lib/ExternalProject_owncloud_android_lib.mk
@@ -0,0 +1,23 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalProject_ExternalProject,owncloud_android_lib))
+
+$(eval $(call gb_ExternalProject_register_targets,owncloud_android_lib,\
+ build \
+))
+
+$(call gb_ExternalProject_get_state_target,owncloud_android_lib,build) :
+ $(call gb_Trace_StartRange,owncloud_android_lib,EXTERNAL)
+ $(call gb_ExternalProject_run,build,\
+ ANDROID_HOME=$(ANDROID_SDK_HOME) $(SRCDIR)/android/source/gradlew assemble \
+ )
+ $(call gb_Trace_EndRange,owncloud_android_lib,EXTERNAL)
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/owncloud-android-lib/Makefile b/external/owncloud-android-lib/Makefile
new file mode 100644
index 000000000..e4968cf85
--- /dev/null
+++ b/external/owncloud-android-lib/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/owncloud-android-lib/Module_owncloud-android-lib.mk b/external/owncloud-android-lib/Module_owncloud-android-lib.mk
new file mode 100644
index 000000000..486ed4053
--- /dev/null
+++ b/external/owncloud-android-lib/Module_owncloud-android-lib.mk
@@ -0,0 +1,17 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,owncloud_android_lib))
+
+$(eval $(call gb_Module_add_targets,owncloud_android_lib, \
+ ExternalProject_owncloud_android_lib \
+ UnpackedTarball_owncloud_android_lib \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/owncloud-android-lib/README b/external/owncloud-android-lib/README
new file mode 100644
index 000000000..921619d63
--- /dev/null
+++ b/external/owncloud-android-lib/README
@@ -0,0 +1,7 @@
+Library required to access ownCloud servers from Android.
+
+Code from https://github.com/jaragunde/owncloud-android-library, release 0.9.4.
+Notice it is a fork from the official repository at
+https://github.com/owncloud/android-library, the test and example projects have
+been removed and the binary jars have been replaced with the sources of the
+required libraries.
diff --git a/external/owncloud-android-lib/UnpackedTarball_owncloud_android_lib.mk b/external/owncloud-android-lib/UnpackedTarball_owncloud_android_lib.mk
new file mode 100644
index 000000000..b9038cd1c
--- /dev/null
+++ b/external/owncloud-android-lib/UnpackedTarball_owncloud_android_lib.mk
@@ -0,0 +1,16 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,owncloud_android_lib))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,owncloud_android_lib,$(OWNCLOUD_ANDROID_LIB_TARBALL)))
+
+$(eval $(call gb_UnpackedTarball_add_file,owncloud_android_lib,build.gradle,external/owncloud-android-lib/build.gradle))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/owncloud-android-lib/build.gradle b/external/owncloud-android-lib/build.gradle
new file mode 100644
index 000000000..9203dc45a
--- /dev/null
+++ b/external/owncloud-android-lib/build.gradle
@@ -0,0 +1,57 @@
+apply plugin: 'com.android.library'
+buildscript {
+ repositories {
+ jcenter()
+ google()
+ }
+ dependencies {
+ classpath 'com.android.tools.build:gradle:3.1.3'
+ }
+}
+
+allprojects {
+ repositories {
+ jcenter()
+ google()
+ }
+}
+
+android {
+ useLibrary 'org.apache.http.legacy'
+
+ compileOptions {
+ encoding 'ISO8859-1'
+ sourceCompatibility JavaVersion.VERSION_1_7
+ targetCompatibility JavaVersion.VERSION_1_7
+ }
+
+ compileSdkVersion 26
+ buildToolsVersion "27.0.3"
+
+ defaultConfig {
+ minSdkVersion 16
+ targetSdkVersion 26
+ }
+
+ sourceSets {
+ main {
+ manifest.srcFile 'AndroidManifest.xml'
+ java {
+ srcDirs = [
+ 'libs/commons-codec-1.9/src/main/java',
+ 'libs/commons-httpclient-3.1/src/java',
+ 'libs/jackrabbit-webdav-2.7.2/src/main/java',
+ 'libs/slf4j-1.7.12/src/java',
+ 'libs/tomcat-7.0.40/java',
+ 'src'
+ ]
+ }
+ resources {
+ srcDirs = [
+ 'libs/tomcat-7.0.40/java',
+ 'libs/jackrabbit-webdav-2.7.2/src/main/java'
+ ]
+ }
+ }
+ }
+}