summaryrefslogtreecommitdiffstats
path: root/odk/config/setsdkenv_unix
diff options
context:
space:
mode:
Diffstat (limited to 'odk/config/setsdkenv_unix')
-rwxr-xr-xodk/config/setsdkenv_unix76
1 files changed, 76 insertions, 0 deletions
diff --git a/odk/config/setsdkenv_unix b/odk/config/setsdkenv_unix
new file mode 100755
index 000000000..cc5f06e64
--- /dev/null
+++ b/odk/config/setsdkenv_unix
@@ -0,0 +1,76 @@
+#! /bin/sh
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+OSTYPE=`uname -s`
+HOSTNAME=`hostname`
+CURRENTDIR=`/bin/pwd`
+SDKTMPDIR=`dirname $0`
+OO_SDK_HOME=`(cd $SDKTMPDIR && pwd && cd $CURRENTDIR) | head -n 1`
+OOVERSION=`cat $OO_SDK_HOME/settings/dk.mk | tail -3 | head -n 1 | cut -d"=" -f2 | cut -d"." -f1,2`
+if [ "$OSTYPE" = "Darwin" ]
+then
+ OO_SDK_NAME=`basename $OO_SDK_HOME`
+else
+ OO_SDK_NAME=libreoffice${OOVERSION}_sdk
+fi
+
+export OO_SDK_HOME
+
+if [ "$1" = "--force-configure" ]
+then
+ if [ -r $HOME/$OO_SDK_NAME/$HOSTNAME/setsdkenv_unix.sh ]
+ then
+ rm $HOME/$OO_SDK_NAME/$HOSTNAME/setsdkenv_unix.sh
+ fi
+ shift
+elif [ "$1" = "-h" ] || [ "$1" = "--help" ] || [ -n "$1" ]
+then
+ echo
+ echo " using: setsdkenv_unix [options]"
+ echo ""
+ echo " options:"
+ echo " --force-configure : force a new configuration of your SDK environment."
+ echo " Alternatively can you edit your SDK environment scripts directly:"
+ echo " $HOME/$OO_SDK_NAME/setsdkenv_unix.sh"
+ echo " -h, --help : print this help and exit"
+ echo
+ exit 1
+fi
+
+# source the prepared environment and start a new shell
+if [ -r $HOME/$OO_SDK_NAME/$HOSTNAME/setsdkenv_unix.sh ]
+then
+ . $HOME/$OO_SDK_NAME/$HOSTNAME/setsdkenv_unix.sh
+else
+ echo
+ echo " ************************************************************************"
+ echo " *"
+ echo " * You have to configure your SDK environment first before you can"
+ echo " * use it. The configuration has to be done only once."
+ echo " *"
+ echo " ************************************************************************"
+ echo
+
+ perl $OO_SDK_HOME/configure.pl $HOSTNAME $OO_SDK_HOME $OO_SDK_NAME
+
+ . $HOME/$OO_SDK_NAME/$HOSTNAME/setsdkenv_unix.sh
+fi
+
+"$SHELL" "$@"
+echo Shell terminated.