summaryrefslogtreecommitdiffstats
path: root/odk/settings/stdtarget.mk
diff options
context:
space:
mode:
Diffstat (limited to 'odk/settings/stdtarget.mk')
-rw-r--r--odk/settings/stdtarget.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/odk/settings/stdtarget.mk b/odk/settings/stdtarget.mk
new file mode 100644
index 000000000..14d131f7e
--- /dev/null
+++ b/odk/settings/stdtarget.mk
@@ -0,0 +1,35 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+.SUFFIXES:
+
+.SECONDARY:
+
+ifeq "$(DEBUG)" "yes"
+debug : ALL
+endif
+
+.PHONY: install
+install: $(REGISTERFLAG)
+
+$(SDKTYPEFLAG): #$(URE_TYPES) $(OFFICE_TYPES)
+# This is a makefile for a standard Make, so must be TABs below
+ -$(MKDIR) $(subst /,$(PS),$(@D))
+ -$(DEL) $(subst \\,\,$(subst /,$(PS),$(SDKTYPEFLAG)))
+ $(CPPUMAKER) -Gc -O$(OUT_INC) $(URE_TYPES) $(OFFICE_TYPES)
+ echo flagged > $@