summaryrefslogtreecommitdiffstats
path: root/test/Library_vclbootstrapprotector.mk
diff options
context:
space:
mode:
Diffstat (limited to 'test/Library_vclbootstrapprotector.mk')
-rw-r--r--test/Library_vclbootstrapprotector.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/test/Library_vclbootstrapprotector.mk b/test/Library_vclbootstrapprotector.mk
new file mode 100644
index 000000000..d01bc6679
--- /dev/null
+++ b/test/Library_vclbootstrapprotector.mk
@@ -0,0 +1,34 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,vclbootstrapprotector))
+
+$(eval $(call gb_Library_add_exception_objects,vclbootstrapprotector, \
+ test/source/vclbootstrapprotector \
+))
+
+$(eval $(call gb_Library_use_externals,vclbootstrapprotector, \
+ boost_headers \
+ cppunit \
+))
+
+$(eval $(call gb_Library_use_libraries,vclbootstrapprotector, \
+ comphelper \
+ cppu \
+ i18nlangtag \
+ sal \
+ test-setupvcl \
+ tl \
+ utl \
+ vcl \
+))
+
+$(eval $(call gb_Library_use_sdk_api,vclbootstrapprotector))
+
+# vim: set noet sw=4 ts=4: