summaryrefslogtreecommitdiffstats
path: root/drivers/soc/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 10:05:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 10:05:51 +0000
commit5d1646d90e1f2cceb9f0828f4b28318cd0ec7744 (patch)
treea94efe259b9009378be6d90eb30d2b019d95c194 /drivers/soc/Makefile
parentInitial commit. (diff)
downloadlinux-5d1646d90e1f2cceb9f0828f4b28318cd0ec7744.tar.xz
linux-5d1646d90e1f2cceb9f0828f4b28318cd0ec7744.zip
Adding upstream version 5.10.209.upstream/5.10.209upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'drivers/soc/Makefile')
-rw-r--r--drivers/soc/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/drivers/soc/Makefile b/drivers/soc/Makefile
new file mode 100644
index 000000000..36452bed8
--- /dev/null
+++ b/drivers/soc/Makefile
@@ -0,0 +1,31 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux Kernel SOC specific device drivers.
+#
+
+obj-$(CONFIG_ARCH_ACTIONS) += actions/
+obj-$(CONFIG_SOC_ASPEED) += aspeed/
+obj-$(CONFIG_ARCH_AT91) += atmel/
+obj-y += bcm/
+obj-$(CONFIG_ARCH_DOVE) += dove/
+obj-$(CONFIG_MACH_DOVE) += dove/
+obj-y += fsl/
+obj-$(CONFIG_ARCH_GEMINI) += gemini/
+obj-y += imx/
+obj-$(CONFIG_ARCH_IXP4XX) += ixp4xx/
+obj-$(CONFIG_SOC_XWAY) += lantiq/
+obj-y += mediatek/
+obj-y += amlogic/
+obj-y += qcom/
+obj-y += renesas/
+obj-$(CONFIG_ARCH_ROCKCHIP) += rockchip/
+obj-$(CONFIG_SOC_SAMSUNG) += samsung/
+obj-$(CONFIG_SOC_SIFIVE) += sifive/
+obj-y += sunxi/
+obj-$(CONFIG_ARCH_TEGRA) += tegra/
+obj-y += ti/
+obj-$(CONFIG_ARCH_U8500) += ux500/
+obj-$(CONFIG_PLAT_VERSATILE) += versatile/
+obj-y += xilinx/
+obj-$(CONFIG_ARCH_ZX) += zte/
+obj-$(CONFIG_SOC_KENDRYTE) += kendryte/