summaryrefslogtreecommitdiffstats
path: root/drivers/tty/serial/cpm_uart/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/tty/serial/cpm_uart/Makefile')
-rw-r--r--drivers/tty/serial/cpm_uart/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/tty/serial/cpm_uart/Makefile b/drivers/tty/serial/cpm_uart/Makefile
new file mode 100644
index 000000000..3f3a6ed02
--- /dev/null
+++ b/drivers/tty/serial/cpm_uart/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Motorola 8xx FEC ethernet controller
+#
+
+obj-$(CONFIG_SERIAL_CPM) += cpm_uart.o
+
+# Select the correct platform objects.
+cpm_uart-objs-$(CONFIG_CPM2) += cpm_uart_cpm2.o
+cpm_uart-objs-$(CONFIG_CPM1) += cpm_uart_cpm1.o
+
+cpm_uart-objs := cpm_uart_core.o $(cpm_uart-objs-y)