summaryrefslogtreecommitdiffstats
path: root/tools/testing/selftests/pidfd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testing/selftests/pidfd/Makefile')
-rw-r--r--tools/testing/selftests/pidfd/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/testing/selftests/pidfd/Makefile b/tools/testing/selftests/pidfd/Makefile
new file mode 100644
index 000000000..f4a2f28f9
--- /dev/null
+++ b/tools/testing/selftests/pidfd/Makefile
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0-only
+CFLAGS += -g -I../../../../usr/include/ -pthread
+
+TEST_GEN_PROGS := pidfd_test pidfd_fdinfo_test pidfd_open_test \
+ pidfd_poll_test pidfd_wait pidfd_getfd_test pidfd_setns_test
+
+include ../lib.mk
+