summaryrefslogtreecommitdiffstats
path: root/tools/testing/selftests/pstore/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testing/selftests/pstore/Makefile')
-rw-r--r--tools/testing/selftests/pstore/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/testing/selftests/pstore/Makefile b/tools/testing/selftests/pstore/Makefile
new file mode 100644
index 000000000..5ef57855a
--- /dev/null
+++ b/tools/testing/selftests/pstore/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0
+# Makefile for pstore selftests.
+# Expects pstore backend is registered.
+
+all:
+
+TEST_PROGS := pstore_tests pstore_post_reboot_tests
+TEST_FILES := common_tests pstore_crash_test
+EXTRA_CLEAN := logs/* *uuid
+
+include ../lib.mk
+
+run_crash:
+ @sh pstore_crash_test || { echo "pstore_crash_test: [FAIL]"; exit 1; }