summaryrefslogtreecommitdiffstats
path: root/debhelper/Debian/Debhelper/Sequence/pgxs_loop.pm
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 12:08:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 12:08:38 +0000
commitd351686a4df1b61f40ada69e53c9522259ad6700 (patch)
tree0322b0d8e7e63c926188aa7b037070f3560ad8dd /debhelper/Debian/Debhelper/Sequence/pgxs_loop.pm
parentInitial commit. (diff)
downloadpostgresql-common-d351686a4df1b61f40ada69e53c9522259ad6700.tar.xz
postgresql-common-d351686a4df1b61f40ada69e53c9522259ad6700.zip
Adding upstream version 225+deb11u1.upstream/225+deb11u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debhelper/Debian/Debhelper/Sequence/pgxs_loop.pm')
-rw-r--r--debhelper/Debian/Debhelper/Sequence/pgxs_loop.pm25
1 files changed, 25 insertions, 0 deletions
diff --git a/debhelper/Debian/Debhelper/Sequence/pgxs_loop.pm b/debhelper/Debian/Debhelper/Sequence/pgxs_loop.pm
new file mode 100644
index 0000000..14d1b61
--- /dev/null
+++ b/debhelper/Debian/Debhelper/Sequence/pgxs_loop.pm
@@ -0,0 +1,25 @@
+#!/usr/bin/perl
+
+use warnings;
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+# check if debian/control needs updating from debian/control.in
+insert_after("dh_clean", "pg_buildext");
+add_command_options("pg_buildext", "checkcontrol");
+
+# use PGXS for clean, build, and install
+add_command_options("dh_auto_clean", "--buildsystem=pgxs_loop");
+add_command_options("dh_auto_build", "--buildsystem=pgxs_loop");
+add_command_options("dh_auto_install", "--buildsystem=pgxs_loop");
+
+# move tests from dh_auto_test to dh_pgxs_test
+remove_command("dh_auto_test");
+# Dh_Lib::hostarch() not yet available on stretch and xenial
+my $hostarch = dpkg_architecture_value('DEB_HOST_ARCH');
+if (! get_buildoption("nocheck") and $hostarch ne "hurd-i386") {
+ insert_after("dh_link", "dh_pgxs_test");
+ add_command_options("dh_pgxs_test", "loop");
+}
+
+1;