summaryrefslogtreecommitdiffstats
path: root/test/TEST-41-ONESHOT-RESTART
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-41-ONESHOT-RESTART')
l---------test/TEST-41-ONESHOT-RESTART/Makefile1
-rwxr-xr-xtest/TEST-41-ONESHOT-RESTART/test.sh6
2 files changed, 7 insertions, 0 deletions
diff --git a/test/TEST-41-ONESHOT-RESTART/Makefile b/test/TEST-41-ONESHOT-RESTART/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-41-ONESHOT-RESTART/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-41-ONESHOT-RESTART/test.sh b/test/TEST-41-ONESHOT-RESTART/test.sh
new file mode 100755
index 0000000..d3f96ae
--- /dev/null
+++ b/test/TEST-41-ONESHOT-RESTART/test.sh
@@ -0,0 +1,6 @@
+#!/usr/bin/env bash
+set -e
+TEST_DESCRIPTION="Test oneshot unit restart on failure"
+. $TEST_BASE_DIR/test-functions
+
+do_test "$@" 41