summaryrefslogtreecommitdiffstats
path: root/src/VBox/Frontends/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:19:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:19:18 +0000
commit4035b1bfb1e5843a539a8b624d21952b756974d1 (patch)
treef1e9cd5bf548cbc57ff2fddfb2b4aa9ae95587e2 /src/VBox/Frontends/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-upstream.tar.xz
virtualbox-upstream.zip
Adding upstream version 6.1.22-dfsg.upstream/6.1.22-dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/Frontends/Makefile.kmk')
-rw-r--r--src/VBox/Frontends/Makefile.kmk58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/VBox/Frontends/Makefile.kmk b/src/VBox/Frontends/Makefile.kmk
new file mode 100644
index 00000000..6cc39f37
--- /dev/null
+++ b/src/VBox/Frontends/Makefile.kmk
@@ -0,0 +1,58 @@
+# $Id: Makefile.kmk $
+## @file
+# Top-level makefile for the VBox frontends.
+#
+
+#
+# Copyright (C) 2006-2020 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+# Include Sub-Makefiles
+ifdef VBOX_WITH_MAIN
+ include $(PATH_SUB_CURRENT)/VBoxManage/Makefile.kmk
+endif
+ifndef VBOX_ONLY_DOCS
+ ifdef VBOX_WITH_MAIN
+ ifdef VBOX_WITH_FE_BALLOONCTRL
+ include $(PATH_SUB_CURRENT)/VBoxBalloonCtrl/Makefile.kmk
+ endif
+ ifdef VBOX_WITH_FE_AUTOSTART
+ include $(PATH_SUB_CURRENT)/VBoxAutostart/Makefile.kmk
+ endif
+ ifdef VBOX_WITH_FE_BUGREPORT
+ include $(PATH_SUB_CURRENT)/VBoxBugReport/Makefile.kmk
+ endif
+ endif
+ ifdef VBOX_WITH_VBOXSDL
+ include $(PATH_SUB_CURRENT)/VBoxSDL/Makefile.kmk
+ endif
+ ifdef VBOX_WITH_VBOXFB
+ include $(PATH_SUB_CURRENT)/VBoxFB/Makefile.kmk
+ endif
+ ifdef VBOX_WITH_HEADLESS
+ include $(PATH_SUB_CURRENT)/VBoxHeadless/Makefile.kmk
+ endif
+ ifdef VBOX_WITH_QTGUI
+ include $(PATH_SUB_CURRENT)/VirtualBox/Makefile.kmk
+ endif
+ include $(PATH_SUB_CURRENT)/Common/Makefile.kmk
+endif # !VBOX_ONLY_DOCS
+
+## @todo Include Python shell into binary delivery?
+ifdef VBOX_ONLY_SDK
+ include $(PATH_SUB_CURRENT)/VBoxShell/Makefile.kmk
+endif
+
+include $(FILE_KBUILD_SUB_FOOTER)
+