summaryrefslogtreecommitdiffstats
path: root/debian/patches/12-make-module.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/12-make-module.patch')
-rw-r--r--debian/patches/12-make-module.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/patches/12-make-module.patch b/debian/patches/12-make-module.patch
new file mode 100644
index 00000000..cb6e1fd2
--- /dev/null
+++ b/debian/patches/12-make-module.patch
@@ -0,0 +1,14 @@
+Description: Fix ARCH setting in modules Makefiles.
+Author: Michael Meskes <meskes@debian.org>, Gianfranco Costamagna <locutusofborg@debian.org>
+
+--- a/src/VBox/Installer/linux/Makefile-header.gmk
++++ b/src/VBox/Installer/linux/Makefile-header.gmk
+@@ -45,7 +45,7 @@
+ # (We have to support basic cross building (ARCH=i386|x86_64).)
+ # While at it, warn about BUILD_* vars found to help with user problems.
+ #
+-ifeq ($(filter-out x86_64 amd64 AMD64,$(shell uname -m)),)
++ifeq ($(filter-out x86_64 amd64 AMD64,$(shell dpkg-architecture -qDEB_HOST_GNU_CPU)),)
+ BUILD_TARGET_ARCH_DEF := amd64
+ else
+ BUILD_TARGET_ARCH_DEF := x86