summaryrefslogtreecommitdiffstats
path: root/src/VBox/Runtime/darwin
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Runtime/darwin')
-rw-r--r--src/VBox/Runtime/darwin/Makefile.kup0
-rw-r--r--src/VBox/Runtime/darwin/RTErrConvertFromDarwin.cpp129
-rw-r--r--src/VBox/Runtime/darwin/RTErrConvertFromDarwinCOM.cpp64
-rw-r--r--src/VBox/Runtime/darwin/RTErrConvertFromDarwinIO.cpp46
-rw-r--r--src/VBox/Runtime/darwin/RTErrConvertFromDarwinKern.cpp46
5 files changed, 285 insertions, 0 deletions
diff --git a/src/VBox/Runtime/darwin/Makefile.kup b/src/VBox/Runtime/darwin/Makefile.kup
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/src/VBox/Runtime/darwin/Makefile.kup
diff --git a/src/VBox/Runtime/darwin/RTErrConvertFromDarwin.cpp b/src/VBox/Runtime/darwin/RTErrConvertFromDarwin.cpp
new file mode 100644
index 00000000..6181f147
--- /dev/null
+++ b/src/VBox/Runtime/darwin/RTErrConvertFromDarwin.cpp
@@ -0,0 +1,129 @@
+/* $Id: RTErrConvertFromDarwin.cpp $ */
+/** @file
+ * IPRT - Convert Darwin Mach returns codes to iprt status codes.
+ */
+
+/*
+ * Copyright (C) 2006-2020 Oracle Corporation
+ *
+ * This file is part of VirtualBox Open Source Edition (OSE), as
+ * available from http://www.virtualbox.org. This file is free software;
+ * you can redistribute it and/or modify it under the terms of the GNU
+ * General Public License (GPL) as published by the Free Software
+ * Foundation, in version 2 as it comes in the "COPYING" file of the
+ * VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+ * hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+ *
+ * The contents of this file may alternatively be used under the terms
+ * of the Common Development and Distribution License Version 1.0
+ * (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+ * VirtualBox OSE distribution, in which case the provisions of the
+ * CDDL are applicable instead of those of the GPL.
+ *
+ * You may elect to license modified versions of this file under the
+ * terms and conditions of either the GPL or the CDDL or both.
+ */
+
+
+/*********************************************************************************************************************************
+* Header Files *
+*********************************************************************************************************************************/
+#include <mach/kern_return.h>
+#include <IOKit/IOReturn.h>
+
+#include <iprt/err.h>
+#include <iprt/log.h>
+#include <iprt/assert.h>
+
+
+RTDECL(int) RTErrConvertFromDarwin(int iNativeCode)
+{
+ /*
+ * 'optimized' success case.
+ */
+ if (iNativeCode == KERN_SUCCESS)
+ return VINF_SUCCESS;
+
+ switch (iNativeCode)
+ {
+ /*
+ * Mach.
+ */
+ case KERN_INVALID_ADDRESS: return VERR_INVALID_POINTER;
+ case KERN_PROTECTION_FAILURE: return VERR_PERMISSION_DENIED;
+ //case KERN_NO_SPACE:
+ case KERN_INVALID_ARGUMENT: return VERR_INVALID_PARAMETER;
+ //case KERN_FAILURE:
+ //case KERN_RESOURCE_SHORTAGE:
+ //case KERN_NOT_RECEIVER:
+ case KERN_NO_ACCESS: return VERR_ACCESS_DENIED;
+ //case KERN_MEMORY_FAILURE:
+ //case KERN_MEMORY_ERROR:
+ //case KERN_ALREADY_IN_SET:
+ //case KERN_NOT_IN_SET:
+ //case KERN_NAME_EXISTS:
+ //case KERN_ABORTED:
+ //case KERN_INVALID_NAME:
+ //case KERN_INVALID_TASK:
+ //case KERN_INVALID_RIGHT:
+ //case KERN_INVALID_VALUE:
+ //case KERN_UREFS_OVERFLOW:
+ //case KERN_INVALID_CAPABILITY:
+ //case KERN_RIGHT_EXISTS:
+ //case KERN_INVALID_HOST:
+ //case KERN_MEMORY_PRESENT:
+ //case KERN_MEMORY_DATA_MOVED:
+ //case KERN_MEMORY_RESTART_COPY:
+ //case KERN_INVALID_PROCESSOR_SET:
+ //case KERN_POLICY_LIMIT:
+ //case KERN_INVALID_POLICY:
+ //case KERN_INVALID_OBJECT:
+ //case KERN_ALREADY_WAITING:
+ //case KERN_DEFAULT_SET:
+ //case KERN_EXCEPTION_PROTECTED:
+ //case KERN_INVALID_LEDGER:
+ //case KERN_INVALID_MEMORY_CONTROL:
+ //case KERN_INVALID_SECURITY:
+ //case KERN_NOT_DEPRESSED:
+ //case KERN_TERMINATED:
+ //case KERN_LOCK_SET_DESTROYED:
+ //case KERN_LOCK_UNSTABLE:
+ case KERN_LOCK_OWNED: return VERR_SEM_BUSY;
+ //case KERN_LOCK_OWNED_SELF:
+ case KERN_SEMAPHORE_DESTROYED: return VERR_SEM_DESTROYED;
+ //case KERN_RPC_SERVER_TERMINATED:
+ //case KERN_RPC_TERMINATE_ORPHAN:
+ //case KERN_RPC_CONTINUE_ORPHAN:
+ case KERN_NOT_SUPPORTED: return VERR_NOT_SUPPORTED;
+ //case KERN_NODE_DOWN:
+ //case KERN_NOT_WAITING:
+ case KERN_OPERATION_TIMED_OUT: return VERR_TIMEOUT;
+
+
+ /*
+ * I/O Kit.
+ */
+ case kIOReturnNoDevice: return VERR_IO_BAD_UNIT;
+ case kIOReturnUnsupported: return VERR_NOT_SUPPORTED;
+ case kIOReturnInternalError: return VERR_INTERNAL_ERROR;
+ case kIOReturnNoResources: return VERR_OUT_OF_RESOURCES;
+ case kIOReturnBadArgument: return VERR_INVALID_PARAMETER;
+ case kIOReturnCannotWire: return VERR_LOCK_FAILED;
+
+#ifdef IN_RING3
+ /*
+ * CoreFoundation COM (may overlap with I/O Kit and Mach).
+ */
+ default:
+ if ( (unsigned)iNativeCode >= 0x80000000U
+ && (unsigned)iNativeCode <= 0x8000FFFFU)
+ return RTErrConvertFromDarwinCOM(iNativeCode);
+ break;
+#endif /* IN_RING3 */
+ }
+
+ /* unknown error. */
+ AssertLogRelMsgFailed(("Unhandled error %#x\n", iNativeCode));
+ return VERR_UNRESOLVED_ERROR;
+}
+
diff --git a/src/VBox/Runtime/darwin/RTErrConvertFromDarwinCOM.cpp b/src/VBox/Runtime/darwin/RTErrConvertFromDarwinCOM.cpp
new file mode 100644
index 00000000..540e989c
--- /dev/null
+++ b/src/VBox/Runtime/darwin/RTErrConvertFromDarwinCOM.cpp
@@ -0,0 +1,64 @@
+/* $Id: RTErrConvertFromDarwinCOM.cpp $ */
+/** @file
+ * IPRT - Convert Darwin COM returns codes to iprt status codes.
+ */
+
+/*
+ * Copyright (C) 2006-2020 Oracle Corporation
+ *
+ * This file is part of VirtualBox Open Source Edition (OSE), as
+ * available from http://www.virtualbox.org. This file is free software;
+ * you can redistribute it and/or modify it under the terms of the GNU
+ * General Public License (GPL) as published by the Free Software
+ * Foundation, in version 2 as it comes in the "COPYING" file of the
+ * VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+ * hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+ *
+ * The contents of this file may alternatively be used under the terms
+ * of the Common Development and Distribution License Version 1.0
+ * (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+ * VirtualBox OSE distribution, in which case the provisions of the
+ * CDDL are applicable instead of those of the GPL.
+ *
+ * You may elect to license modified versions of this file under the
+ * terms and conditions of either the GPL or the CDDL or both.
+ */
+
+
+/*********************************************************************************************************************************
+* Header Files *
+*********************************************************************************************************************************/
+#include <IOKit/IOCFPlugIn.h>
+
+#include <iprt/err.h>
+#include <iprt/log.h>
+#include <iprt/assert.h>
+
+
+RTDECL(int) RTErrConvertFromDarwinCOM(int32_t iNativeCode)
+{
+ /*
+ * 'optimized' success case.
+ */
+ if (iNativeCode == S_OK)
+ return VINF_SUCCESS;
+
+ switch (iNativeCode)
+ {
+ //case E_UNEXPECTED:
+ case E_NOTIMPL: return VERR_NOT_IMPLEMENTED;
+ case E_OUTOFMEMORY: return VERR_NO_MEMORY;
+ case E_INVALIDARG: return VERR_INVALID_PARAMETER;
+ //case E_NOINTERFACE: return VERR_NOT_SUPPORTED;
+ case E_POINTER: return VERR_INVALID_POINTER;
+ case E_HANDLE: return VERR_INVALID_HANDLE;
+ //case E_ABORT: return VERR_CANCELLED;
+ case E_FAIL: return VERR_GENERAL_FAILURE;
+ case E_ACCESSDENIED: return VERR_ACCESS_DENIED;
+ }
+
+ /* unknown error. */
+ AssertLogRelMsgFailed(("Unhandled error %#x\n", iNativeCode));
+ return VERR_UNRESOLVED_ERROR;
+}
+
diff --git a/src/VBox/Runtime/darwin/RTErrConvertFromDarwinIO.cpp b/src/VBox/Runtime/darwin/RTErrConvertFromDarwinIO.cpp
new file mode 100644
index 00000000..d1ea3c37
--- /dev/null
+++ b/src/VBox/Runtime/darwin/RTErrConvertFromDarwinIO.cpp
@@ -0,0 +1,46 @@
+/* $Id: RTErrConvertFromDarwinIO.cpp $ */
+/** @file
+ * IPRT - Convert Darwin IOKit returns codes to iprt status codes.
+ */
+
+/*
+ * Copyright (C) 2006-2020 Oracle Corporation
+ *
+ * This file is part of VirtualBox Open Source Edition (OSE), as
+ * available from http://www.virtualbox.org. This file is free software;
+ * you can redistribute it and/or modify it under the terms of the GNU
+ * General Public License (GPL) as published by the Free Software
+ * Foundation, in version 2 as it comes in the "COPYING" file of the
+ * VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+ * hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+ *
+ * The contents of this file may alternatively be used under the terms
+ * of the Common Development and Distribution License Version 1.0
+ * (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+ * VirtualBox OSE distribution, in which case the provisions of the
+ * CDDL are applicable instead of those of the GPL.
+ *
+ * You may elect to license modified versions of this file under the
+ * terms and conditions of either the GPL or the CDDL or both.
+ */
+
+
+/*********************************************************************************************************************************
+* Header Files *
+*********************************************************************************************************************************/
+#include <IOKit/IOReturn.h>
+
+#include <iprt/errcore.h>
+#include <iprt/assert.h>
+
+
+RTDECL(int) RTErrConvertFromDarwinIO(int iNativeCode)
+{
+ /*
+ * 'optimized' success case.
+ */
+ if (iNativeCode == kIOReturnSuccess)
+ return VINF_SUCCESS;
+ return RTErrConvertFromDarwin(iNativeCode);
+}
+
diff --git a/src/VBox/Runtime/darwin/RTErrConvertFromDarwinKern.cpp b/src/VBox/Runtime/darwin/RTErrConvertFromDarwinKern.cpp
new file mode 100644
index 00000000..589b8a3f
--- /dev/null
+++ b/src/VBox/Runtime/darwin/RTErrConvertFromDarwinKern.cpp
@@ -0,0 +1,46 @@
+/* $Id: RTErrConvertFromDarwinKern.cpp $ */
+/** @file
+ * IPRT - Convert Darwin Mach returns codes to iprt status codes.
+ */
+
+/*
+ * Copyright (C) 2006-2020 Oracle Corporation
+ *
+ * This file is part of VirtualBox Open Source Edition (OSE), as
+ * available from http://www.virtualbox.org. This file is free software;
+ * you can redistribute it and/or modify it under the terms of the GNU
+ * General Public License (GPL) as published by the Free Software
+ * Foundation, in version 2 as it comes in the "COPYING" file of the
+ * VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+ * hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+ *
+ * The contents of this file may alternatively be used under the terms
+ * of the Common Development and Distribution License Version 1.0
+ * (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+ * VirtualBox OSE distribution, in which case the provisions of the
+ * CDDL are applicable instead of those of the GPL.
+ *
+ * You may elect to license modified versions of this file under the
+ * terms and conditions of either the GPL or the CDDL or both.
+ */
+
+
+/*********************************************************************************************************************************
+* Header Files *
+*********************************************************************************************************************************/
+#include <mach/kern_return.h>
+
+#include <iprt/errcore.h>
+#include <iprt/assert.h>
+
+
+RTDECL(int) RTErrConvertFromDarwinKern(int iNativeCode)
+{
+ /*
+ * 'optimized' success case.
+ */
+ if (iNativeCode == KERN_SUCCESS)
+ return VINF_SUCCESS;
+ return RTErrConvertFromDarwin(iNativeCode);
+}
+