summaryrefslogtreecommitdiffstats
path: root/msdos
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 17:47:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 17:47:50 +0000
commitbbe35a6e1b54ef5cd7c1c471886c30ba85c0804e (patch)
tree985a31e8c860c690d9f20e6621ce5fcc05ccd244 /msdos
parentInitial commit. (diff)
downloadwget-upstream.tar.xz
wget-upstream.zip
Adding upstream version 1.21.upstream/1.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'msdos')
-rw-r--r--msdos/Makefile.DJ89
-rw-r--r--msdos/Makefile.WC67
-rw-r--r--msdos/config.h141
3 files changed, 297 insertions, 0 deletions
diff --git a/msdos/Makefile.DJ b/msdos/Makefile.DJ
new file mode 100644
index 0000000..5ae5fec
--- /dev/null
+++ b/msdos/Makefile.DJ
@@ -0,0 +1,89 @@
+#
+# GNU Makefile for wget / djgpp / MSDOS.
+# By Gisle Vanem <gvanem@broadpark.no> 2009.
+#
+# `cd' to `./src' and issue the command:
+# make -f ../msdos/Makefile.dj depend
+# followed by:
+# make -f ../msdos/Makefile.dj
+#
+VERSION = 1.12 (djgpp/DOS)
+
+.SUFFIXES: .exe
+
+VPATH = ../lib ../md5 ../msdos
+
+USE_OPENSSL = 0
+USE_IPV6 = 1
+
+#
+# Change to suite.
+#
+OPENSSL_ROOT = e:/net/OpenSSL.099
+ZLIB_ROOT = e:/djgpp/contrib/zlib
+
+OBJ_DIR = djgpp.obj
+CC = gcc
+CFLAGS = -O2 -g -Wall -Wcast-align -I. -I../msdos -I../lib -I../md5 \
+ -I/dev/env/WATT_ROOT/inc -DHAVE_CONFIG_H -DENABLE_DEBUG \
+ -DUSE_WATT32
+
+# LDFLAGS = -s
+
+ifeq ($(USE_OPENSSL),1)
+ CFLAGS += -DHAVE_OPENSSL -DHAVE_SSL -DOPENSSL_NO_KRB5 -I$(OPENSSL_ROOT)
+ EX_LIBS += $(OPENSSL_ROOT)/lib/libssl.a $(OPENSSL_ROOT)/lib/libcrypt.a \
+ $(ZLIB_ROOT)/libz.a
+ SOURCES += openssl.c http-ntlm.c
+endif
+
+ifeq ($(USE_IPV6),1)
+ CFLAGS += -DENABLE_IPV6
+endif
+
+EX_LIBS += /dev/env/WATT_ROOT/lib/libwatt.a
+
+SOURCES += cmpt.c connect.c cookies.c exits.c ftp.c ftp-basic.c ftp-ls.c \
+ ftp-opie.c hash.c host.c html-parse.c html-url.c http.c \
+ init.c log.c main.c gen-md5.c netrc.c progress.c recur.c \
+ res.c retr.c snprintf.c url.c utils.c version.c convert.c \
+ ptimer.c spider.c css.c css-url.c build_info.c ../md5/md5.c \
+ ../msdos/msdos.c \
+ $(addprefix ../lib/, error.c exitfail.c quote.c \
+ quotearg.c getopt.c getopt1.c xalloc-die.c xmalloc.c)
+
+OBJECTS = $(addprefix $(OBJ_DIR)/, $(notdir $(SOURCES:.c=.o)))
+
+all: $(OBJ_DIR) wget.exe
+ @echo 'Welcome to Wget'
+
+$(OBJ_DIR):
+ mkdir $(OBJ_DIR)
+
+wget.exe: $(OBJECTS)
+ $(CC) $(LDFLAGS) -o $@ $^ $(EX_LIBS)
+
+css.c: css.l
+ flex -8 -o$@ $^
+
+clean:
+ rm -f $(OBJ_DIR)/*.o $(MAPFILE)
+
+vclean realclean: clean
+ rm -f wget.exe depend.dj version.c
+ - rmdir $(OBJ_DIR)
+
+$(OBJ_DIR)/%.o: %.c
+ $(CC) $(CFLAGS) -o $@ -c $<
+ @echo
+
+version.c: ../msdos/Makefile.DJ
+ @echo 'char *version_string = "$(VERSION)";' > $@
+ @echo 'char *compilation_string = "$(CC) $(CFLAGS)";' >> $@
+ @echo 'char *link_string = "$(CC) $(LDFLAGS) -o wget.exe $$(OBJECTS) $(EX_LIBS)";' >> $@
+
+depend: version.c
+ $(CC) -MM $(CFLAGS) $(SOURCES) | \
+ sed -e 's/^\([a-zA-Z0-9_-]*\.o:\)/$$(OBJ_DIR)\/\1/' > depend.dj
+
+-include depend.dj
diff --git a/msdos/Makefile.WC b/msdos/Makefile.WC
new file mode 100644
index 0000000..d93f068
--- /dev/null
+++ b/msdos/Makefile.WC
@@ -0,0 +1,67 @@
+#
+# Makefile for Wget / DOS32A / OpenWatcom
+# by G. Vanem <gvanem@broadpark.no> 2009
+#
+
+VERSION = 1.12 (Watcom/DOS)
+
+COMPILE = *wcc386 -mf -3r -w3 -d2 -zq -zm -of -I. -I$(%watt_root)\inc &
+ -I..\msdos -I..\lib -I..\md5 -fr=nul -bt=dos -s -dHAVE_CONFIG_H &
+ -dENABLE_DEBUG -dSIZEOF_INT=4 -dUSE_WATT32
+
+LINK = *wlink option quiet, map, verbose, eliminate, caseexact, stack=100k &
+ debug all system dos32a
+
+.c: ..\lib
+.c: ..\md5
+.c: ..\msdos
+
+
+OBJ_DIR = WC_DOS.obj
+
+OBJECTS = $(OBJ_DIR)\cmpt.obj $(OBJ_DIR)\build_info.obj &
+ $(OBJ_DIR)\c-ctype.obj $(OBJ_DIR)\cookies.obj &
+ $(OBJ_DIR)\connect.obj $(OBJ_DIR)\convert.obj &
+ $(OBJ_DIR)\css.obj $(OBJ_DIR)\css-url.obj &
+ $(OBJ_DIR)\error.obj $(OBJ_DIR)\exits.obj &
+ $(OBJ_DIR)\exitfail.obj $(OBJ_DIR)\ftp-basic.obj &
+ $(OBJ_DIR)\ftp-ls.obj $(OBJ_DIR)\ftp-opie.obj &
+ $(OBJ_DIR)\ftp.obj $(OBJ_DIR)\gen-md5.obj &
+ $(OBJ_DIR)\getopt.obj $(OBJ_DIR)\getopt1.obj &
+ $(OBJ_DIR)\hash.obj $(OBJ_DIR)\msdos.obj &
+ $(OBJ_DIR)\host.obj $(OBJ_DIR)\html-parse.obj &
+ $(OBJ_DIR)\html-url.obj $(OBJ_DIR)\http.obj &
+ $(OBJ_DIR)\init.obj $(OBJ_DIR)\log.obj &
+ $(OBJ_DIR)\main.obj $(OBJ_DIR)\md5.obj &
+ $(OBJ_DIR)\netrc.obj $(OBJ_DIR)\progress.obj &
+ $(OBJ_DIR)\ptimer.obj $(OBJ_DIR)\recur.obj &
+ $(OBJ_DIR)\res.obj $(OBJ_DIR)\retr.obj &
+ $(OBJ_DIR)\spider.obj $(OBJ_DIR)\url.obj &
+ $(OBJ_DIR)\utils.obj $(OBJ_DIR)\version.obj &
+ $(OBJ_DIR)\xalloc-die.obj $(OBJ_DIR)\xmalloc.obj &
+ $(OBJ_DIR)\quote.obj $(OBJ_DIR)\quotearg.obj
+
+all: $(OBJ_DIR) wget.exe .SYMBOLIC
+ @echo 'Welcome to Wget / Watcom'
+
+$(OBJ_DIR):
+ - mkdir $^@
+
+.ERASE
+.c{$(OBJ_DIR)}.obj: .AUTODEPEND
+ *$(COMPILE) -fo=$@ $[@
+
+css.c: css.l
+ flex -8 -o$@ $[@
+
+wget.exe: $(OBJECTS)
+ $(LINK) name $@ file { $(OBJECTS) } library $(%watt_root)\lib\wattcpwf.lib
+
+version.c: ..\msdos\Makefile.WC
+ @echo char *version_string = "$(VERSION)"; > $@
+ @echo char *compilation_string = "$(COMPILE)"; >> $@
+ @echo char *link_string = "$(LINK) name wget.exe file { $$(OBJECTS) }"; >> $@
+
+clean: .SYMBOLIC
+ - rm $(OBJ_DIR)\*.obj wget.exe wget.map version.c css.c
+ - rmdir $(OBJ_DIR)
diff --git a/msdos/config.h b/msdos/config.h
new file mode 100644
index 0000000..35fb72a
--- /dev/null
+++ b/msdos/config.h
@@ -0,0 +1,141 @@
+/* Configuration header file for MS-DOS/Watt-32
+ Copyright (C) 2007, 2008, 2009, 2010, 2011, 2015 Free Software
+ Foundation, Inc.
+
+ This file is part of GNU Wget.
+
+ GNU Wget is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ GNU Wget is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with Wget. If not, see <http://www.gnu.org/licenses/>.
+
+ Additional permission under GNU GPL version 3 section 7
+
+ If you modify this program, or any covered work, by linking or
+ combining it with the OpenSSL project's OpenSSL library (or a
+ modified version of that library), containing parts covered by the
+ terms of the OpenSSL or SSLeay licenses, the Free Software Foundation
+ grants you additional permission to convey the resulting work.
+ Corresponding Source for a non-source form of such a combination
+ shall include the source code for the parts of OpenSSL used as well
+ as that of the covered work. */
+
+
+#ifndef CONFIG_DOS_H
+#define CONFIG_DOS_H
+
+#include <stdlib.h>
+#include <limits.h>
+#include <tcp.h>
+#include <malloc.h>
+
+#ifdef __DJGPP__
+#include <sys/config.h>
+#endif
+
+#include <sys/errno.h>
+
+#if defined(__WATCOMC__)
+ #if (__WATCOMC__ >= 1250) /* OW 1.5+ */
+ #define OPENWATCOM_15
+ #endif
+ #if (__WATCOMC__ >= 1270) /* OW 1.7+ */
+ #define OPENWATCOM_17
+ #endif
+#endif
+
+#if defined(__HIGHC__)
+ #define HAVE_UNISTD_H 1
+ #define HAVE_UTIME_H 1
+#endif
+
+#if defined(__WATCOMC__) || defined(__BORLANDC__) || defined(__HIGHC__)
+ #define inline
+#endif
+
+#define USE_OPIE 1
+#define USE_DIGEST 1
+#define DEBUG
+
+#ifdef __DJGPP__
+ #define HAVE__BOOL 1
+ #define HAVE_STRCASECMP 1
+ #define HAVE_STRNCASECMP 1
+ #define HAVE_SIGSETJMP 1
+ #define HAVE_SIGBLOCK 1
+ #define HAVE_STRUCT_UTIMBUF 1
+ #define HAVE_SYS_SELECT_H 1
+ #define HAVE_USLEEP 1
+ #define HAVE_UTIME_H 1
+ #define HAVE_INT64_T 1
+
+ #if (DJGPP_MINOR >= 4)
+ #define HAVE_STDBOOL_H 1
+ #define HAVE_STDINT_H 1
+ #define HAVE_SNPRINTF 1
+ #define HAVE_VSNPRINTF 1
+ #define HAVE_UINT32_T 1
+ #endif
+#endif
+
+#ifdef __HIGHC__
+ #define HAVE_STRUCT_UTIMBUF 1
+ #define HAVE_UTIME_H 1
+#endif
+
+#ifdef OPENWATCOM_15
+ #define HAVE_ALLOCA_H 1
+ #define HAVE_INT64_T 1
+ #define HAVE_SNPRINTF 1
+ #define HAVE_STRCASECMP 1
+ #define HAVE_STRNCASECMP 1
+ #define HAVE_STDINT_H 1
+ #define HAVE_UTIME_H 1
+#endif
+
+#ifdef OPENWATCOM_17
+ #define HAVE__BOOL 1
+ #define HAVE_STDBOOL_H 1
+#endif
+
+#define HAVE_PROCESS_H 1
+#define HAVE_STRDUP 1
+#define HAVE_STDLIB_H 1
+#define HAVE_STRING_H 1
+#define HAVE_BUILTIN_MD5 1
+#define HAVE_ISATTY 1
+
+#define lookup_host wget_lookuphost
+#define select select_s
+#define socklen_t int
+
+#define sock_read wget_sock_read
+#define sock_write wget_sock_write
+#define sock_close wget_sock_close
+
+#if !defined(__DJGPP__)
+ #include <direct.h>
+ #define mkdir(p,a) (mkdir)(p)
+ #define strcasecmp stricmp
+#endif
+
+#if !defined(MSDOS)
+ #define MSDOS
+#endif
+
+#if !defined(USE_WATT32)
+ #define USE_WATT32
+#endif
+
+#define LOCALEDIR ""
+#define OS_TYPE "DOS"
+
+#endif /* CONFIG_DOS_H */