summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 13:45:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 13:45:26 +0000
commitea13660109d7a1bdcc72562c377cf6e627a46799 (patch)
tree392fcd2295d2351eff2feeeee4b609214ef7217e
parentAdding upstream version 0.30.0. (diff)
downloadxserver-xorg-input-libinput-ea13660109d7a1bdcc72562c377cf6e627a46799.tar.xz
xserver-xorg-input-libinput-ea13660109d7a1bdcc72562c377cf6e627a46799.zip
Adding debian version 0.30.0-1.debian/0.30.0-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--.gitlab-ci.yml55
-rw-r--r--ChangeLog451
-rw-r--r--autogen.sh17
-rw-r--r--debian/README.source49
-rw-r--r--debian/changelog162
-rw-r--r--debian/control62
-rw-r--r--debian/copyright52
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules20
-rw-r--r--debian/upstream/signing-key.asc24
-rw-r--r--debian/watch4
-rw-r--r--debian/xserver-xorg-input-libinput-dev.install2
-rw-r--r--debian/xserver-xorg-input-libinput-udeb.install2
-rw-r--r--debian/xserver-xorg-input-libinput.install3
-rw-r--r--debian/xserver-xorg-input-libinput.links1
15 files changed, 455 insertions, 450 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 0000000..0397f91
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,55 @@
+# vim: set expandtab shiftwidth=2 tabstop=8 textwidth=0:
+
+include:
+ - project: 'freedesktop/ci-templates'
+ ref: 59de540b620c45739871d1a073d76d5521989d11 # see https://docs.gitlab.com/ee/ci/yaml/#includefile
+ file: '/templates/fedora.yml'
+
+
+variables:
+ FDO_UPSTREAM_REPO: xorg/drivers/xf86-input-libinput
+
+
+stages:
+ - containers
+ - build
+
+
+.fedora:
+ variables:
+ FDO_DISTRIBUTION_VERSION: 32
+ FDO_DISTRIBUTION_PACKAGES: 'git autoconf automake libtool make xorg-x11-server-devel libudev-devel libevdev-devel libinput-devel xorg-x11-util-macros'
+ FDO_DISTRIBUTION_TAG: '2020-05-19.0'
+
+
+fedora@container_build:
+ extends:
+ - .fedora
+ - .fdo.container-build@fedora
+ stage: containers
+ variables:
+ GIT_STRATEGY: none
+
+
+.default_build:
+ stage: build
+ script:
+ - mkdir _builddir _inst
+ - pushd _builddir > /dev/null
+ - ../autogen.sh --prefix=$(realpath ../_inst) --disable-silent-rules
+ - make && make check
+ - make install
+ - popd > /dev/null
+ artifacts:
+ name: "automake-logs-$CI_JOB_NAME"
+ when: always
+ expire_in: 1 week
+ paths:
+ - _builddir/config.log
+
+
+fedora:32@default-build:
+ extends:
+ - .fedora
+ - .fdo.distribution-image@fedora
+ - .default_build
diff --git a/ChangeLog b/ChangeLog
index 12a16b2..494ce99 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,449 +1,3 @@
-commit 583ed5acdc17a4dc7848c891d7cdbd35ff07b781
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue May 19 15:37:30 2020 +1000
-
- xf86-input-libinput 0.30.0
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit e8e5d1a6b579c6bd5e6c9e76a53f13ca77fa0d5f
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue May 19 15:57:52 2020 +1000
-
- gitlab CI: update to latest CI templates
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 639b21d78a80566477163993366400e506f6e7b7
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue May 19 15:47:00 2020 +1000
-
- gitlab CI: bump to Fedora 32
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit e52daf203bb690e33b27514cb8fc76b263e6622a
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Fri Oct 11 10:24:30 2019 +1000
-
- Implement support for scroll button locks
-
- Add a boolean option/property to enable/disable the scroll button lock. Where
- enabled, the button can be clicked and released as opposed to having to be
- held down.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 400bf493d1840e72dc3bad624707b4934fe5de33
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Aug 12 12:35:51 2019 +1000
-
- xf86-input-libinput 0.29.0
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 27a88897bedb8dca41be311a162243ec7f4a952d
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Aug 12 10:57:11 2019 +1000
-
- Add basic Gitlab CI for testing the build
-
- This merely tests against the devel package in Fedora, not against the xserver
- from git. Should be enough, the driver here doesn't change enough to need the
- git builds.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit d5867e5db6300ba2fa08054f16af661bd0ae4200
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Aug 12 10:35:15 2019 +1000
-
- Fix compiler warning about unhandled switch events
-
- This bumps the required libinput version to 1.7 - which has been out for over
- two years now. That's conservative enough.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 1ef2ed874e700a6be9091c01df5b432a3e4d8b2e
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Jul 30 11:23:46 2019 +1000
-
- Check for the tool type too when creating subdevices
-
- Fixed #25
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 3c9052d8865200818a3e98ea9077df54829e724c
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Jul 30 11:10:55 2019 +1000
-
- Fix wrong enum type
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 39b0bb4585106a56a51236d8e9843b2da8d745a5
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Jul 30 11:46:50 2019 +1000
-
- Revert "Upgrade the default scroll distance to 120"
-
- This was part of the high-resolution wheel work that was factored out ahead of
- time. Problem is: this breaks scroll button emulation in the server as we
- use the distance to determine when we click buttons 4-7.
-
- Before: movement of 15 normalized pixel units on a touchpad - one click. Now:
- 120 of those units. So that's a bit less than ideal.
-
- The change to 120 can be done, but needs the corresponding handling in the
- axis distance calculations.
-
- Fixes #24
-
- This reverts commit 055481187d44b10ba220398a1ca46f4854fd76ee.
-
-commit 8923d18d25303354f250b4f165fa66b327b8ac7e
-Author: David Rosca <nowrep@gmail.com>
-Date: Mon Feb 25 18:26:08 2019 +0100
-
- Also use type to match tablet tool with device
-
- On devices with tools having both serial and id 0,
- it would fail to create separate subdevices.
-
- Thinkpad X220T (Wacom ISDv4 E6) now correctly registers
- Pen and Eraser xinput devices.
-
-commit 055481187d44b10ba220398a1ca46f4854fd76ee
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Wed Jan 23 09:01:24 2019 +1000
-
- Upgrade the default scroll distance to 120
-
- This is just a number, to be used as divider and shouldn't have any effect in
- correctly written clients. With the high-res scrolling coming up however, we
- have a few devices where the dist cannot be expressed as an integer fraction
- of 15, so let's up it to 120 because we know all hardware wheels have to be an
- integer fraction of that that, thanks to Microsoft's API requirements.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 5a925eaa84b31c5857969342802018cb5803475a
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Feb 4 13:14:11 2019 +1000
-
- xf86-input-libinput 0.28.2
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit e7eafa199e9e60c15014a9d72d14efcbbf8e44ca
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Jan 21 15:21:45 2019 +1000
-
- Handle scroll wheel events with a discrete of 0
-
- The driver currently assumes that any wheel event has a non-zero discrete
- value of 1. This is incorrect, it just hasn't triggered yet with any device.
-
- With the hi-res scroll patches in place in the kernel and libinput, we may get
- wheel events with a discrete value of 0. We assume that if this ever happens,
- the device has some sensible click angle set so all we need to do is ignore
- the discrete 0 events and wait for the first discrete event to come.
-
- Also add an explanatory comment too to make it clear the calculation is only
- done once.
-
- Fixes #19
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit d13ab268bdf6eb589022c58ddc87c1211b49ac4c
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Jan 21 13:19:11 2019 +1000
-
- Return the wheel scroll value instead of just the fraction
-
- This is prep work for the hi-res work but right now, no real functional
- changes. It does however fix a bug where we used the vertial scroll dist for
- the horizontal wheel as well.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 347c78387eb3fbadcd582f0ea51bb083962a728f
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Jan 21 13:05:23 2019 +1000
-
- Split the scroll axis details up for easier extension
-
- If we need more per-axis fields, it's easier to add this way.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit b63f7994dc4359900dbb2a29612e0112b6ae5b79
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Jan 7 16:26:47 2019 +1000
-
- conf: add an example snippet for how to assign options
-
- Users still like to copy the whole file, potentially messing things up.
- Let's put a warning into the file directly that this is less than ideal.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 04f42d6e0f99d771cbbab25c896f287fd6697f37
-Author: Alan Coopersmith <alan.coopersmith@oracle.com>
-Date: Sun Nov 25 12:47:32 2018 -0800
-
- Update configure.ac bug URL for gitlab migration
-
- Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
-
-commit 5d341d1d6c389b286279f87d7a3bdb0f5bd275f1
-Author: Alan Coopersmith <alan.coopersmith@oracle.com>
-Date: Sun Nov 18 11:48:07 2018 -0800
-
- Update README for gitlab migration
-
- Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
-
-commit 4985de5ef3e81d32d694c3d4a480a6311b6f1416
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Oct 15 15:29:37 2018 +1000
-
- Remove two dead assignments
-
- Value stored but never read.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit e26fc3c66c04eb3d3164e6a9e7c983154fb00856
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Oct 15 09:36:36 2018 +1000
-
- xf86-input-libinput 0.28.1
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit a759610292a53067fc811e70703bffff8dc0cb16
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Thu Oct 4 11:45:46 2018 +1000
-
- Use the seat slot, not the device slot for touch events
-
- The device slot is per-device, so if we have more than one device we may get a
- touch down event for a slot already in use.
-
- Fixes https://gitlab.freedesktop.org/libinput/libinput/issues/153
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 21ff2ca7d1a771f6dcecb5b73dc1031f77c9dd69
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Thu Jul 19 15:58:06 2018 +1000
-
- Remove unused assignment
-
- dev is our list iterator below, this is a dead assignment
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit c67f191d5bc1a4a130f89743a3ce35ee06c90f85
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Wed Jul 11 11:06:59 2018 +1000
-
- xf86-input-libinput 0.28.0
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 1978a2555b338e5177523046e6338f58a4253951
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Wed Jul 11 10:59:20 2018 +1000
-
- Minor whitespace fix
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 0909a1a76546284f27fb1b17a6f545a04537cc36
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Jul 10 11:17:50 2018 +1000
-
- draglock: fix memory overwrite during draglock parsing
-
- Passing in the size of the array but using it as "number of elements" inside
- the function. Rename a bunch of arguments to avoid this.
-
- https://bugs.freedesktop.org/show_bug.cgi?id=107166
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 20bb8d6b9f4375557472dad67b5f8dcf31be27d3
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Wed May 23 08:14:23 2018 +1000
-
- Revert "Implement the custom acceleration curve options"
-
- Custom pointer acceleration curves were reverted in libinput, so no point
- having this code here.
-
- This reverts commit d84e0035d12a9655c09a6e8c619b1144be42c90c.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 1e88664d958a000ac610ae9000459c461ba45bd8
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Wed May 2 13:59:00 2018 +1000
-
- Use the libinput touch count to init the right number of touches
-
- Initial version by Johannes Pointner <h4nn35.work@gmail.com>
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit d84e0035d12a9655c09a6e8c619b1144be42c90c
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Apr 17 13:51:53 2018 +1000
-
- Implement the custom acceleration curve options
-
- One new property, and the existing accel profile gets extended to keep one
- extra value. The new property libinput Accel Curve Points is a list of pairs
- of points to be added to the acceleration curve.
-
- libinput only supports adding points to the curve so we simply declare the
- behavior as undefined when the curve is set multiple times. Also helps to
- identify those that bother to read the man page before playing with random
- driver values.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 6c75acfcdf6539713c3b62bc2227a4b215d05fdb
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Fri Apr 20 13:33:45 2018 +1000
-
- Use xf86SetStrOption to check for string options
-
- This one shows up in the log and marks it as used.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit eaf847be16de1399aa271b94e4421a3794447462
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Apr 17 15:10:42 2018 +1000
-
- man: whitespace fixes in man page
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit d319092d557ec0280602879b19ef1b0a825e1e75
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Apr 17 13:52:11 2018 +1000
-
- man: fix formatting issue caused by invalid tag
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 18cc042e6822f5f24d06291ead07ea70723f9434
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Apr 10 09:19:52 2018 +1000
-
- xf86-input-libinput 0.27.1
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 0db82219bb2ad10dcdf3ea8fe8e226858190c83b
-Author: Evangelos Foutras <evangelos@foutrelis.com>
-Date: Thu Mar 22 01:47:07 2018 +0200
-
- Fix "left handed" property not set on all pointers
-
- Remove conditional that prevents the LIBINPUT_PROP_LEFT_HANDED{,DEFAULT}
- properties from being set on all pointer devices (only the first got it).
- This appears to be a debugging left-over accidentally merged in
- 6d3bd4544a6a2f194fa.
-
- https://bugs.freedesktop.org/show_bug.cgi?id=105667
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit f93bc148d4e6702d50ce320f6d519753c0af7c42
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue Mar 20 11:23:57 2018 +1000
-
- xf86-input-libinput 0.27.0
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-commit 0d4b50fd6e200cb8b720ee0b917b882d2d03542b
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Mon Mar 19 10:00:59 2018 +1000
-
- man: note that we don't do /dev/input/by-id or /dev/input/by-path
-
- For logind-setups we need to match the path libinput wants to open with the
- Option Device path that the device has so we know when to return the
- server-fd. This doesn't work for by-id or by-path because libinput resolves
- those (through udev) to the actual eventX node so our paths look different
- when they are the same device.
-
- This could be fixed but since this is easy enough to work around with a
- InputClass section and rather a niche case, it's not really worth the effort.
-
- https://bugs.freedesktop.org/show_bug.cgi?id=105562
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
- Reviewed-by: Adam Jackson <ajax@redhat.com>
-
-commit 9d9f59fd4c5a57e4663b19c3cace6f78202c4689
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Fri Feb 2 13:54:32 2018 +1000
-
- Apply the capabilities checks on subdevices when applying the config
-
- Properties are initialized on the correct devices only but on resume we'd just
- blindly apply the config from our device. Depending on the resume order, this
- would mean we'd apply a previously set config with a default config.
-
- Example:
- * pointer device with keyboard subdevice
- * pointer device exports natural scrolling, keyboard device does not and
- remains at default (off)
- * client enables natural scrolling on the pointer device
- * VT switch away, VT switch back
- * pointer device gets enabled first, enables natural scrolling on the
- libinput device
- * keyboard device gets enabled second, resets to the default value
-
- Reported-by: Yuxuan Shui <yshuiv7@gmail.com>
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
- Tested-by: Yuxuan Shui <yshuiv7@gmail.com>
-
-commit 73534814909b8b6f4fce8f44b412b2903397bdb0
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Fri Feb 2 13:24:43 2018 +1000
-
- Split LibinputDeviceApplyConfig into helper functions
-
- No functional changes
-
-commit 6d3bd4544a6a2f194fa2ca7e08dca9cc44211e99
-Author: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Fri Feb 2 13:27:11 2018 +1000
-
- Move the subdevice capabilities check into the properties
-
- 87f9fe3a6fafe60134c6's intention was to not create properties that a subdevice
- doesn't have configuration options for (i.e. if you have a pointer+keyboard
- device, don't expose tapping configuration on the keyboard subdevice).
-
- The result was messy, the checker function had a confusing triple-negation and
- some properties weren't checked - e.g. left-handed was allowed for touch/tablet
- but not for pointer, dwt was allowed for any device.
-
- Fix this by moving the check into the property init function directly and
- inverting the helper function to be easier to read.
-
- Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
commit 2be6487de417473aac85ebd800392cdd8604c4a6
Author: Peter Hutterer <peter.hutterer@who-t.net>
Date: Fri Sep 15 11:26:54 2017 +1000
@@ -506,9 +60,6 @@ Date: Mon May 15 03:13:43 2017 +0200
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-Notes (test-jelly):
- SUCCESS: jelly: make check Mon May 15 11:42:39 AEST 2017
-
commit 8772a593b45740f4429218648c9e3a305b3fe896
Author: Martin Kepplinger <martin.kepplinger@ginzinger.com>
Date: Thu May 4 08:49:34 2017 +0200
@@ -573,7 +124,7 @@ Date: Tue Feb 28 14:45:29 2017 +1000
Compiled with -O0:
Breakpoint 1, test_nonzero_x_linear () at test-bezier.c:157
- 157 assert(bezier[x] > bezier[x-1]);
+ 157 assert(bezier[x] > bezier[x-1]);
(gdb) p bezier
$6 = {0 <repeats 409 times>, 1, 2, 4, 5, 7, 9, 10, 12, 14, 15, 17, 19, 21, 22,
diff --git a/autogen.sh b/autogen.sh
new file mode 100644
index 0000000..421528e
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,17 @@
+#! /bin/sh
+
+srcdir=`dirname "$0"`
+test -z "$srcdir" && srcdir=.
+
+ORIGDIR=`pwd`
+cd "$srcdir"
+
+autoreconf -v --install || exit 1
+cd "$ORIGDIR" || exit $?
+
+git config --local --get format.subjectPrefix >/dev/null 2>&1 ||
+ git config --local format.subjectPrefix "PATCH xf86-input-libinput"
+
+if test -z "$NOCONFIGURE"; then
+ exec "$srcdir"/configure "$@"
+fi
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..4ecd5e6
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,49 @@
+------------------------------------------------------
+Quick Guide To Patching This Package For The Impatient
+------------------------------------------------------
+
+1. Make sure you have quilt installed
+2. Unpack the package as usual with "dpkg-source -x"
+3. Run the "patch" target in debian/rules
+4. Create a new patch with "quilt new" (see quilt(1))
+5. Edit all the files you want to include in the patch with "quilt edit"
+ (see quilt(1)).
+6. Write the patch with "quilt refresh" (see quilt(1))
+7. Run the "clean" target in debian/rules
+
+Alternatively, instead of using quilt directly, you can drop the patch in to
+debian/patches and add the name of the patch to debian/patches/series.
+
+------------------------------------
+Guide To The X Strike Force Packages
+------------------------------------
+
+The X Strike Force team maintains X packages in git repositories on
+git.debian.org in the pkg-xorg subdirectory. Most upstream packages
+are actually maintained in git repositories as well, so they often
+just need to be pulled into git.debian.org in a "upstream-*" branch.
+Otherwise, the upstream sources are manually installed in the Debian
+git repository.
+
+The .orig.tar.gz upstream source file could be generated using this
+"upstream-*" branch in the Debian git repository but it is actually
+copied from upstream tarballs directly.
+
+Due to X.org being highly modular, packaging all X.org applications
+as their own independent packages would have created too many Debian
+packages. For this reason, some X.org applications have been grouped
+into larger packages: xutils, xutils-dev, x11-apps, x11-session-utils,
+x11-utils, x11-xfs-utils, x11-xkb-utils, x11-xserver-utils.
+Most packages, including the X.org server itself and all libraries
+and drivers are, however maintained independently.
+
+The Debian packaging is added by creating the "debian-*" git branch
+which contains the aforementioned "upstream-*" branch plus the debian/
+repository files.
+When a patch has to be applied to the Debian package, two solutions
+are involved:
+* If the patch is available in one of the upstream branches, it
+ may be git'cherry-picked into the Debian repository. In this
+ case, it appears directly in the .diff.gz.
+* Otherwise, the patch is added to debian/patches/ which is managed
+ with quilt as documented in /usr/share/doc/quilt/README.source.
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..98377e5
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,162 @@
+xserver-xorg-input-libinput (0.30.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ * rules: Use dh_missing.
+ * control: Migrate to debhelper-compat, bump to 12.
+ * control: Bump policy to 4.5.0.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Mon, 17 Aug 2020 13:45:44 +0300
+
+xserver-xorg-input-libinput (0.29.0-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Tue, 13 Aug 2019 14:13:23 +0300
+
+xserver-xorg-input-libinput (0.28.2-2) unstable; urgency=medium
+
+ * Ship configuration snippet in the udeb as well.
+
+ -- Cyril Brulebois <kibi@debian.org> Sun, 31 Mar 2019 01:56:52 +0000
+
+xserver-xorg-input-libinput (0.28.2-1) unstable; urgency=medium
+
+ * New upstream release.
+ * control: Bump policy to 4.3.0, no changes.
+ * control: Update vcs urls.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Mon, 04 Feb 2019 10:48:58 +0200
+
+xserver-xorg-input-libinput (0.28.1-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Tue, 16 Oct 2018 07:48:27 +0300
+
+xserver-xorg-input-libinput (0.28.0-1) unstable; urgency=medium
+
+ * New upstream release. (LP: #1786478)
+
+ -- Timo Aaltonen <tjaalton@debian.org> Fri, 17 Aug 2018 15:04:00 +0300
+
+xserver-xorg-input-libinput (0.27.1-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Wed, 11 Apr 2018 10:50:09 +0300
+
+xserver-xorg-input-libinput (0.27.0-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Tue, 20 Mar 2018 13:33:52 +0200
+
+xserver-xorg-input-libinput (0.26.0-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Sat, 23 Sep 2017 14:47:01 +0300
+
+xserver-xorg-input-libinput (0.23.0-2) unstable; urgency=medium
+
+ [ Andreas Boll ]
+ * Cherry-pick commit f47f78e (Ignore LED updates for disabled devices)
+ from upstream master branch (Closes: #829386).
+ * Switch URLs to https.
+ * Move URL from description to Homepage field.
+ * Bump Standards-Version to 3.9.8.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Thu, 12 Jan 2017 13:48:06 +0200
+
+xserver-xorg-input-libinput (0.23.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ * Bump debhelper compat to 10.
+ + Let debhelper run autoreconf for us.
+ * No need to pass --disable-silent-rules to configure, debhelper does
+ that these days.
+ * No need for --destdir=debian/tmp as we have multiple binary packages.
+
+ -- Emilio Pozuelo Monfort <pochu@debian.org> Mon, 12 Dec 2016 19:15:41 +0100
+
+xserver-xorg-input-libinput (0.22.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ * control: Bump build-dep on libinput-dev.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Fri, 18 Nov 2016 16:03:02 +0200
+
+xserver-xorg-input-libinput (0.20.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ * control, rules: Drop -dbg package.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Fri, 30 Sep 2016 15:05:19 +0300
+
+xserver-xorg-input-libinput (0.19.1-1) unstable; urgency=medium
+
+ * Team upload.
+ * Use https URL in debian/watch.
+ * New upstream release.
+
+ -- Julien Cristau <jcristau@debian.org> Sat, 24 Sep 2016 15:58:15 +0200
+
+xserver-xorg-input-libinput (0.19.0-1) unstable; urgency=medium
+
+ [ Andreas Boll ]
+ * control: Fix Vcs-Git field.
+
+ [ Timo Aaltonen ]
+ * New upstream release.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Tue, 10 May 2016 11:37:55 +0300
+
+xserver-xorg-input-libinput (0.18.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ * control: Update the description to mention that this driver can
+ replace -evdev and -synaptics.
+ * control: Bump libinput-dev build-dependency.
+ * control: Bump Standards-Version to 3.9.7 (no changes).
+
+ -- Timo Aaltonen <tjaalton@debian.org> Thu, 07 Apr 2016 10:20:31 +0300
+
+xserver-xorg-input-libinput (0.17.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ * control: Update Vcs fields to use https.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Sat, 27 Feb 2016 10:03:43 +0200
+
+xserver-xorg-input-libinput (0.16.0-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Thu, 14 Jan 2016 14:59:15 +0200
+
+xserver-xorg-input-libinput (0.15.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ * control: Bump libinput-dev build-dep.
+ * install: Fix conf snippet source path.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Wed, 28 Oct 2015 18:30:03 +0200
+
+xserver-xorg-input-libinput (0.14.0-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Timo Aaltonen <tjaalton@debian.org> Wed, 23 Sep 2015 13:12:50 +0300
+
+xserver-xorg-input-libinput (0.13.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ * control: Bump libinput build-dep (Closes: #794032).
+
+ -- Timo Aaltonen <tjaalton@debian.org> Fri, 07 Aug 2015 09:12:38 +0300
+
+xserver-xorg-input-libinput (0.11.0-1) unstable; urgency=medium
+
+ * Initial release. (Closes: #784114)
+
+ -- Timo Aaltonen <tjaalton@debian.org> Mon, 06 Jul 2015 16:27:42 +0300
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..b02cf17
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,62 @@
+Source: xserver-xorg-input-libinput
+Section: x11
+Priority: optional
+Maintainer: Debian X Strike Force <debian-x@lists.debian.org>
+Uploaders: Timo Aaltonen <tjaalton@debian.org>,
+Build-Depends:
+ debhelper-compat (= 12),
+ libinput-dev (>= 1.4.901),
+ libudev-dev,
+ pkg-config,
+ quilt,
+ x11proto-core-dev,
+ x11proto-input-dev (>= 2.2),
+ xserver-xorg-dev (>= 2:1.15.99),
+ xutils-dev,
+Standards-Version: 4.5.0
+Homepage: https://www.x.org
+Vcs-Git: https://salsa.debian.org/xorg-team/driver/xserver-xorg-input-libinput.git
+Vcs-Browser: https://salsa.debian.org/xorg-team/driver/xserver-xorg-input-libinput
+
+Package: xserver-xorg-input-libinput
+Architecture: linux-any
+Depends:
+ ${shlibs:Depends},
+ ${misc:Depends},
+ ${xinpdriver:Depends},
+Provides:
+ ${xinpdriver:Provides}
+Description: X.Org X server -- libinput input driver
+ This package provides the driver for input devices using libinput library.
+ It can handle keyboards, mice and touchpads, and essentially replaces the
+ separate -evdev and -synaptics drivers.
+ .
+ This package is built from the X.org xf86-input-libinput driver module.
+
+Package: xserver-xorg-input-libinput-dev
+Section: libdevel
+Architecture: all
+Depends:
+ ${shlibs:Depends},
+ ${misc:Depends}
+Description: X.Org X server -- libinput input driver (development headers)
+ This package provides the development headers for the libinput input driver
+ found in xserver-xorg-input-libinput. Non-developers likely have little use
+ for this package.
+ .
+ This package is built from the X.org xf86-input-libinput driver module.
+
+
+Package: xserver-xorg-input-libinput-udeb
+XC-Package-Type: udeb
+Section: debian-installer
+Architecture: linux-any
+Depends:
+ ${shlibs:Depends},
+ ${misc:Depends},
+ ${xinpdriver:Depends},
+ udev-udeb,
+Provides:
+ ${xinpdriver:Provides}
+Description: X.Org X server -- libinput input driver
+ This is a udeb, or a microdeb, for the debian-installer.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..da4af0f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,52 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-name: xf86-input-libinput
+Source: https://xorg.freedesktop.org/releases/individual/driver/
+
+Files: *
+Copyright: 2013-2014 Red Hat, Inc.
+License: MIT
+
+Files: configure.ac
+Copyright: 2005 Adam Jackson
+License: xorg
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the "Software"),
+ to deal in the Software without restriction, including without limitation
+ on the rights to use, copy, modify, merge, publish, distribute, sub
+ license, and/or sell copies of the Software, and to permit persons to whom
+ the Software is furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice (including the next
+ paragraph) shall be included in all copies or substantial portions of the
+ Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+ ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+ IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Files: debian/*
+Copyright: 2014 Timo Aaltonen <tjaalton@debian.org>
+License: MIT
+
+License: MIT
+ Permission to use, copy, modify, distribute, and sell this software
+ and its documentation for any purpose is hereby granted without
+ fee, provided that the above copyright notice appear in all copies
+ and that both that copyright notice and this permission notice
+ appear in supporting documentation, and that the name of the authors
+ not be used in advertising or publicity pertaining to distribution of the
+ software without specific, written prior permission. The authors make no
+ representations about the suitability of this software for any
+ purpose. It is provided "as is" without express or implied
+ warranty.
+ .
+ THE AUTHORS DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+ INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+ NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+ CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+ OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+ NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+ CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..fdffa2a
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+# placeholder
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..24da150
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libdir=\$${exec_prefix}/lib
+
+# Kill *.la files, and forget no-one:
+override_dh_install:
+ find debian/tmp -name '*.la' -delete
+ dh_install
+
+override_dh_missing:
+ dh_missing --fail-missing
+
+# That's a plugin, use appropriate warning level:
+override_dh_shlibdeps:
+ dh_shlibdeps -- --warnings=6
+
+%:
+ dh $@ --with quilt,xsf --builddirectory=build/
diff --git a/debian/upstream/signing-key.asc b/debian/upstream/signing-key.asc
new file mode 100644
index 0000000..a141a05
--- /dev/null
+++ b/debian/upstream/signing-key.asc
@@ -0,0 +1,24 @@
+-----BEGIN PGP PUBLIC KEY BLOCK-----
+Version: GnuPG v1
+
+mQGiBD8b0wYRBACph9kRJmP+4+JGsCgFlFoy4vFO0DCG+jmkQN0n1wdInt/N/UtA
+sZToO72AUmfmYizA+IEbzBrx0UnUo3w3BDmHxUWf/akZiPUz9AA/YFY4xC3MY2OK
+VN2Jz6YSce4zJ5jd2ZRobHm4HuIf/8yqSCcsv7FNfrLaTNIFRs5gYYsqZwCgwmkp
+RSLRc8WAnHrTWNQDaEFM2rUEAKTjrTjMN8+KGd0BxNX7HiTSqQP++nXNwAYs1oWB
+Yt82YHj9SvRCqCzD1pzJQivYnlNoWDza1VeMnfdAvkdia8z4lYbO/RunXZJvra3Z
+VDm+izq+uwUAyvFuEYnNz09VSqwXKT6+XW0Xtz2vHq52r6DS6mK8cGJHZ5OhrRjq
+UEYxA/9STh+QfA98xtNoRcf52E/46r7IpCj440oRVc9lMfxQZrLGQNqp7sPdIhGQ
+CCo2NUII5hkhdAG71kpbfSXU4Sh32p1cU1KYCAkDFfb49bKuAs+Pff8v6FGZxTdd
+AinPZr4BbsYJatk818aTCnu0+s7L8jL5GPfeyuyEMKwzVBx2mLQpUGV0ZXIgSHV0
+dGVyZXIgKFdoby1UKSA8b2ZmaWNlQHdoby10Lm5ldD6IWQQTEQIAGQUCPxvTBgQL
+BwMCAxUCAwMWAgECHgECF4AACgkQ4jt+cLRn8L/0RACfWo3KTMUg+uPRqA6RXxk0
+4CWjXaMAoJeIxOpZLB3RBltPnSi7PyVQIkHFuQENBD8b0wgQBACTnqOYOWYVR8O1
+D73J6nbdAeZCbXrUkyXIuyqBOdKmX/0QJmSs7Wfsa+hPfDhj6ai0Gs2C8Qg/0Pzk
+86b4p9DLkf0M6RaYjUtCJBpS59xrsV6nz6xZzQa4RRdf1YJmw2tia1MMXzxbwQU2
+bKpYEm8NsGaBURMGd02EvsMN2wI2uwADBQP/e9MjVr/85XDzAlUBN8HwYW5szTyP
+8ZVcQOqOmNebkTWGLvkPrBdXmxpzrWjxPolO1WcWQjUL0bN/rbdqefT65iVHJHJZ
+/cpTtgGlCPhL5JTA50ltd0I13CABYWLFmswonXES/6tcglf4rr3Nri2sOrY5HggP
+ipEzOo5vdKOow/qIRgQYEQIABgUCPxvTCAAKCRDiO35wtGfwv68jAKCDvL2gkrg1
+4NfV7rNc057K1nL2GgCeKApWRgGVzaOkAp0P5tQulaDD6zM=
+=7uBX
+-----END PGP PUBLIC KEY BLOCK-----
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..be52508
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+#git=git://anongit.freedesktop.org/xorg/driver/xf86-input-libinput
+version=3
+opts=pgpsigurlmangle=s/$/.sig/ \
+https://xorg.freedesktop.org/releases/individual/driver/ xf86-input-libinput-(.*)\.tar\.gz
diff --git a/debian/xserver-xorg-input-libinput-dev.install b/debian/xserver-xorg-input-libinput-dev.install
new file mode 100644
index 0000000..9af15bc
--- /dev/null
+++ b/debian/xserver-xorg-input-libinput-dev.install
@@ -0,0 +1,2 @@
+usr/include/xorg/libinput-properties.h
+usr/lib/pkgconfig/*
diff --git a/debian/xserver-xorg-input-libinput-udeb.install b/debian/xserver-xorg-input-libinput-udeb.install
new file mode 100644
index 0000000..19c904c
--- /dev/null
+++ b/debian/xserver-xorg-input-libinput-udeb.install
@@ -0,0 +1,2 @@
+usr/lib/xorg/modules/input/*.so
+usr/share/X11/xorg.conf.d
diff --git a/debian/xserver-xorg-input-libinput.install b/debian/xserver-xorg-input-libinput.install
new file mode 100644
index 0000000..46ae395
--- /dev/null
+++ b/debian/xserver-xorg-input-libinput.install
@@ -0,0 +1,3 @@
+usr/lib/xorg/modules/input/*.so
+usr/share/man
+usr/share/X11/xorg.conf.d
diff --git a/debian/xserver-xorg-input-libinput.links b/debian/xserver-xorg-input-libinput.links
new file mode 100644
index 0000000..63e0f1d
--- /dev/null
+++ b/debian/xserver-xorg-input-libinput.links
@@ -0,0 +1 @@
+usr/share/bug/xserver-xorg-core/script usr/share/bug/xserver-xorg-input-libinput/script