summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian/0001-build.patch19
-rw-r--r--debian/patches/debian/0002-zupdate.patch15
-rw-r--r--debian/patches/series2
3 files changed, 36 insertions, 0 deletions
diff --git a/debian/patches/debian/0001-build.patch b/debian/patches/debian/0001-build.patch
new file mode 100644
index 0000000..eedfd3e
--- /dev/null
+++ b/debian/patches/debian/0001-build.patch
@@ -0,0 +1,19 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Avoid overwriting build-environment.
+
+diff -Naurp zutils.orig/configure zutils/configure
+--- zutils.orig/configure
++++ zutils/configure
+@@ -21,9 +21,9 @@ infodir='$(datarootdir)/info'
+ mandir='$(datarootdir)/man'
+ sysconfdir='$(prefix)/etc'
+ CXX=g++
+-CPPFLAGS=
+-CXXFLAGS='-Wall -W -O2'
+-LDFLAGS=
++#CPPFLAGS=
++#CXXFLAGS='-Wall -W -O2'
++#LDFLAGS=
+ DIFF=diff
+ GREP=grep
+
diff --git a/debian/patches/debian/0002-zupdate.patch b/debian/patches/debian/0002-zupdate.patch
new file mode 100644
index 0000000..d14c73b
--- /dev/null
+++ b/debian/patches/debian/0002-zupdate.patch
@@ -0,0 +1,15 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Avoid linking zupdate statically.
+
+diff -Naurp zutils.orig/Makefile.in zutils/Makefile.in
+--- zutils.orig/Makefile.in
++++ zutils/Makefile.in
+@@ -51,7 +51,7 @@ ztest : $(ztest_objs)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(ztest_objs)
+
+ zupdate : $(zupdate_objs)
+- $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(zupdate_objs)
++ $(CXX) $(CXXFLAGS) -o $@ $(zupdate_objs)
+
+ rc.o : rc.cc
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -DPROGVERSION=\"$(pkgversion)\" -DSYSCONFDIR=\"$(sysconfdir)\" -c -o $@ $<
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..a353e88
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+debian/0001-build.patch
+debian/0002-zupdate.patch