summaryrefslogtreecommitdiffstats
path: root/qa/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /qa/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'qa/CMakeLists.txt')
-rw-r--r--qa/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/qa/CMakeLists.txt b/qa/CMakeLists.txt
new file mode 100644
index 000000000..a8726141b
--- /dev/null
+++ b/qa/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(CEPH_BUILD_VIRTUALENV $ENV{TMPDIR})
+if(NOT CEPH_BUILD_VIRTUALENV)
+ set(CEPH_BUILD_VIRTUALENV ${CMAKE_BINARY_DIR})
+endif()
+
+if(WITH_TESTS)
+ include(AddCephTest)
+ add_tox_test(qa TOX_ENVS flake8 mypy deadsymlinks)
+endif()