summaryrefslogtreecommitdiffstats
path: root/selinux/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /selinux/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'selinux/CMakeLists.txt')
-rw-r--r--selinux/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/selinux/CMakeLists.txt b/selinux/CMakeLists.txt
new file mode 100644
index 000000000..d0a7e54fb
--- /dev/null
+++ b/selinux/CMakeLists.txt
@@ -0,0 +1,11 @@
+add_custom_target(
+ ceph.pp ALL
+ COMMAND ln -sf ${CMAKE_CURRENT_SOURCE_DIR}/ceph.* .
+ COMMAND make -f ${SELINUX_MAKEFILE} ceph.pp
+ DEPENDS ceph.te ceph.fc ceph.if)
+
+set(datadir ${CMAKE_INSTALL_PREFIX}/share/selinux)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ceph.pp
+ DESTINATION ${datadir}/packages)
+install(FILES ceph.if
+ DESTINATION ${datadir}/devel/include/contrib)