summaryrefslogtreecommitdiffstats
path: root/src/arrow/c_glib/parquet-glib/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/arrow/c_glib/parquet-glib/meson.build
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/arrow/c_glib/parquet-glib/meson.build')
-rw-r--r--src/arrow/c_glib/parquet-glib/meson.build83
1 files changed, 83 insertions, 0 deletions
diff --git a/src/arrow/c_glib/parquet-glib/meson.build b/src/arrow/c_glib/parquet-glib/meson.build
new file mode 100644
index 000000000..73cd9e45c
--- /dev/null
+++ b/src/arrow/c_glib/parquet-glib/meson.build
@@ -0,0 +1,83 @@
+# -*- indent-tabs-mode: nil -*-
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+project_name = 'parquet-glib'
+
+sources = files(
+ 'arrow-file-reader.cpp',
+ 'arrow-file-writer.cpp',
+)
+
+c_headers = files(
+ 'arrow-file-reader.h',
+ 'arrow-file-writer.h',
+ 'parquet-glib.h',
+)
+
+cpp_headers = files(
+ 'arrow-file-reader.hpp',
+ 'arrow-file-writer.hpp',
+ 'parquet-glib.hpp',
+)
+
+headers = c_headers + cpp_headers
+install_headers(headers, subdir: project_name)
+
+
+dependencies = [
+ arrow,
+ parquet,
+ arrow_glib,
+]
+libparquet_glib = library('parquet-glib',
+ sources: sources,
+ install: true,
+ dependencies: dependencies,
+ include_directories: base_include_directories,
+ soversion: so_version,
+ version: library_version)
+parquet_glib = declare_dependency(link_with: libparquet_glib,
+ include_directories: base_include_directories,
+ dependencies: dependencies)
+
+pkgconfig.generate(libparquet_glib,
+ filebase: project_name,
+ name: 'Apache Parquet GLib',
+ description: 'C API for Apache Parquet based on GLib',
+ version: version,
+ requires: ['parquet', 'arrow-glib'])
+
+if have_gi
+ gnome.generate_gir(libparquet_glib,
+ dependencies: declare_dependency(sources: arrow_glib_gir),
+ sources: sources + c_headers,
+ namespace: 'Parquet',
+ nsversion: api_version,
+ identifier_prefix: 'GParquet',
+ symbol_prefix: 'gparquet',
+ export_packages: 'parquet-glib',
+ includes: [
+ 'Arrow-1.0',
+ ],
+ install: true,
+ extra_args: [
+ '--warn-all',
+ '--include-uninstalled=./arrow-glib/Arrow-1.0.gir',
+ ])
+endif