summaryrefslogtreecommitdiffstats
path: root/src/arrow/dev/tasks/conda-recipes/parquet-cpp/meta.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/arrow/dev/tasks/conda-recipes/parquet-cpp/meta.yaml
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/arrow/dev/tasks/conda-recipes/parquet-cpp/meta.yaml')
-rw-r--r--src/arrow/dev/tasks/conda-recipes/parquet-cpp/meta.yaml51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/arrow/dev/tasks/conda-recipes/parquet-cpp/meta.yaml b/src/arrow/dev/tasks/conda-recipes/parquet-cpp/meta.yaml
new file mode 100644
index 000000000..5de06c32b
--- /dev/null
+++ b/src/arrow/dev/tasks/conda-recipes/parquet-cpp/meta.yaml
@@ -0,0 +1,51 @@
+# ARROW-3229: this is a meta-package to prevent conflicts in the future
+
+{% set parquet_version = "1.5.1" %}
+
+package:
+ name: parquet-cpp
+ version: {{ parquet_version }}
+
+build:
+ number: 0
+ skip: true # [win32]
+ skip: true # [win and py<35]
+
+requirements:
+ host:
+ # NOTE: in the upstream feedstock use >= instead of =
+ - arrow-cpp ={{ ARROW_VERSION }}
+ run:
+ - arrow-cpp ={{ ARROW_VERSION }}
+
+test:
+ commands:
+ # headers
+ - test -f $PREFIX/include/parquet/api/reader.h # [unix]
+ - if not exist %LIBRARY_INC%\\parquet\\api\\reader.h exit 1 # [win]
+
+ # shared
+ - test -f $PREFIX/lib/libparquet.so # [linux]
+ - test -f $PREFIX/lib/libparquet.dylib # [osx]
+ - if not exist %PREFIX%\\Library\\bin\\parquet.dll exit 1 # [win]
+
+ # absence of static libraries
+ - test ! -f $PREFIX/lib/libparquet.a # [unix]
+ - if exist %PREFIX%\\Library\\lib\\parquet_static.lib exit 1 # [win]
+
+about:
+ home: http://github.com/apache/arrow
+ license: Apache 2.0
+ summary: 'C++ libraries for the Apache Parquet file format'
+
+extra:
+ recipe-maintainers:
+ - wesm
+ - xhochy
+ - leifwalsh
+ - jreback
+ - cpcloud
+ - siddharthteotia
+ - kou
+ - kszucs
+ - pitrou