summaryrefslogtreecommitdiffstats
path: root/src/arrow/python/.gitignore
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/arrow/python/.gitignore
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/arrow/python/.gitignore')
-rw-r--r--src/arrow/python/.gitignore45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/arrow/python/.gitignore b/src/arrow/python/.gitignore
new file mode 100644
index 000000000..ef1237a2d
--- /dev/null
+++ b/src/arrow/python/.gitignore
@@ -0,0 +1,45 @@
+thirdparty/
+CMakeFiles/
+CMakeCache.txt
+CTestTestfile.cmake
+Makefile
+cmake_install.cmake
+build/
+Testing/
+
+# Python stuff
+
+# Editor temporary/working/backup files
+*flymake*
+
+# Generated sources
+*.c
+*.cpp
+pyarrow/*_api.h
+pyarrow/_generated_version.py
+
+# Bundled headers
+pyarrow/include
+
+# setup.py working directory
+build
+# setup.py dist directory
+dist
+# Coverage
+.coverage
+coverage.xml
+htmlcov
+# Cache
+.cache
+
+# benchmark working dir
+.asv
+pyarrow/_table_api.h
+
+# manylinux temporary files
+manylinux1/arrow
+nm_arrow.log
+visible_symbols.log
+
+# plasma store
+pyarrow/plasma-store-server