summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/polygon/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/boost/libs/polygon/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/polygon/CMakeLists.txt')
-rw-r--r--src/boost/libs/polygon/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/boost/libs/polygon/CMakeLists.txt b/src/boost/libs/polygon/CMakeLists.txt
new file mode 100644
index 000000000..88a5affa2
--- /dev/null
+++ b/src/boost/libs/polygon/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyright 2018 Glen Joseph Fernandes
+# (glenjofe@gmail.com)
+#
+# Distributed under the Boost Software License, Version 1.0.
+# (http://www.boost.org/LICENSE_1_0.txt)
+
+cmake_minimum_required(VERSION 3.5...3.20)
+
+project(boost_polygon VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
+
+add_library(boost_polygon INTERFACE)
+
+add_library(Boost::polygon ALIAS boost_polygon)
+
+target_include_directories(boost_polygon INTERFACE include)
+
+target_link_libraries(boost_polygon
+ INTERFACE
+ Boost::config
+)