summaryrefslogtreecommitdiffstats
path: root/src/ceph-node-proxy/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-23 16:45:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-23 16:45:44 +0000
commit17d6a993fc17d533460c5f40f3908c708e057c18 (patch)
tree1a3bd93e0ecd74fa02f93a528fe2f87e5314c4b5 /src/ceph-node-proxy/setup.py
parentReleasing progress-linux version 18.2.2-0progress7.99u1. (diff)
downloadceph-17d6a993fc17d533460c5f40f3908c708e057c18.tar.xz
ceph-17d6a993fc17d533460c5f40f3908c708e057c18.zip
Merging upstream version 18.2.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/ceph-node-proxy/setup.py')
-rw-r--r--src/ceph-node-proxy/setup.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/ceph-node-proxy/setup.py b/src/ceph-node-proxy/setup.py
new file mode 100644
index 000000000..7dcc7cdf5
--- /dev/null
+++ b/src/ceph-node-proxy/setup.py
@@ -0,0 +1,39 @@
+from setuptools import setup, find_packages
+import os
+
+
+setup(
+ name='ceph-node-proxy',
+ version='1.0.0',
+ packages=find_packages(),
+
+ author='',
+ author_email='gabrioux@ibm.com',
+ description='node-proxy agent to inventory and report hardware statuses.',
+ license='LGPLv2+',
+ keywords='ceph hardware inventory monitoring',
+ url='https://github.com/ceph/ceph',
+ zip_safe=False,
+ install_requires='ceph',
+ dependency_links=[''.join(['file://', os.path.join(os.getcwd(), '../',
+ 'python-common#egg=ceph-1.0.0')])],
+ tests_require=[
+ 'pytest >=2.1.3',
+ 'tox',
+ 'ceph',
+ ],
+ entry_points=dict(
+ console_scripts=[
+ 'ceph-node-proxy = ceph_node_proxy.main:main',
+ ],
+ ),
+ classifiers=[
+ 'Environment :: Console',
+ 'Intended Audience :: Information Technology',
+ 'Intended Audience :: System Administrators',
+ 'Operating System :: POSIX :: Linux',
+ 'License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3.9',
+ ]
+)