summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/opentelemetry-cpp/sdk/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/jaegertracing/opentelemetry-cpp/sdk/test/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/jaegertracing/opentelemetry-cpp/sdk/test/CMakeLists.txt')
-rw-r--r--src/jaegertracing/opentelemetry-cpp/sdk/test/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/jaegertracing/opentelemetry-cpp/sdk/test/CMakeLists.txt b/src/jaegertracing/opentelemetry-cpp/sdk/test/CMakeLists.txt
new file mode 100644
index 000000000..dc8cc2b22
--- /dev/null
+++ b/src/jaegertracing/opentelemetry-cpp/sdk/test/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_subdirectory(common)
+add_subdirectory(trace)
+if(WITH_METRICS_PREVIEW)
+ add_subdirectory(_metrics)
+else()
+ add_subdirectory(metrics)
+endif()
+if(WITH_LOGS_PREVIEW)
+ add_subdirectory(logs)
+endif()
+add_subdirectory(resource)
+add_subdirectory(instrumentationlibrary)