summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/net/pcap/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/seastar/dpdk/drivers/net/pcap/meson.build
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/seastar/dpdk/drivers/net/pcap/meson.build')
-rw-r--r--src/seastar/dpdk/drivers/net/pcap/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/net/pcap/meson.build b/src/seastar/dpdk/drivers/net/pcap/meson.build
new file mode 100644
index 000000000..2c2fd11e4
--- /dev/null
+++ b/src/seastar/dpdk/drivers/net/pcap/meson.build
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+pcap_dep = dependency('pcap', required: false)
+if pcap_dep.found()
+ build = true
+else
+ # pcap got a pkg-config file only in 1.9.0 and before that meson uses
+ # an internal pcap-config finder, which is not compatible with
+ # cross-compilation, so try to fallback to find_library
+ pcap_dep = cc.find_library('pcap', required: false)
+ if pcap_dep.found() and cc.has_header('pcap.h', dependencies: pcap_dep)
+ build = true
+ pkgconfig_extra_libs += '-lpcap'
+ else
+ build = false
+ endif
+endif
+sources = files('rte_eth_pcap.c')
+ext_deps += pcap_dep