summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/drivers/mempool/octeontx2/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/spdk/dpdk/drivers/mempool/octeontx2/meson.build
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/dpdk/drivers/mempool/octeontx2/meson.build')
-rw-r--r--src/spdk/dpdk/drivers/mempool/octeontx2/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/spdk/dpdk/drivers/mempool/octeontx2/meson.build b/src/spdk/dpdk/drivers/mempool/octeontx2/meson.build
new file mode 100644
index 000000000..9fde40f0e
--- /dev/null
+++ b/src/spdk/dpdk/drivers/mempool/octeontx2/meson.build
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(C) 2019 Marvell International Ltd.
+#
+
+sources = files('otx2_mempool_ops.c',
+ 'otx2_mempool.c',
+ 'otx2_mempool_irq.c',
+ 'otx2_mempool_debug.c'
+ )
+
+extra_flags = []
+# This integrated controller runs only on a arm64 machine, remove 32bit warnings
+if not dpdk_conf.get('RTE_ARCH_64')
+ extra_flags += ['-Wno-int-to-pointer-cast', '-Wno-pointer-to-int-cast']
+endif
+
+foreach flag: extra_flags
+ if cc.has_argument(flag)
+ cflags += flag
+ endif
+endforeach
+
+deps += ['eal', 'mbuf', 'kvargs', 'bus_pci', 'common_octeontx2', 'mempool']