summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/drivers/net/dpaa2/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/spdk/dpdk/drivers/net/dpaa2/meson.build
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/dpdk/drivers/net/dpaa2/meson.build')
-rw-r--r--src/spdk/dpdk/drivers/net/dpaa2/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/spdk/dpdk/drivers/net/dpaa2/meson.build b/src/spdk/dpdk/drivers/net/dpaa2/meson.build
new file mode 100644
index 000000000..6dd0eb274
--- /dev/null
+++ b/src/spdk/dpdk/drivers/net/dpaa2/meson.build
@@ -0,0 +1,27 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright 2018 NXP
+
+if not is_linux
+ build = false
+ reason = 'only supported on linux'
+endif
+
+deps += ['mempool_dpaa2']
+sources = files('base/dpaa2_hw_dpni.c',
+ 'dpaa2_mux.c',
+ 'dpaa2_ethdev.c',
+ 'dpaa2_flow.c',
+ 'dpaa2_rxtx.c',
+ 'dpaa2_sparser.c',
+ 'mc/dpkg.c',
+ 'mc/dpdmux.c',
+ 'mc/dpni.c')
+
+if dpdk_conf.has('RTE_LIBRTE_IEEE1588')
+ sources += files('mc/dprtc.c')
+ sources += files('dpaa2_ptp.c')
+endif
+
+includes += include_directories('base', 'mc')
+
+install_headers('rte_pmd_dpaa2.h')