summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/drivers/net/hns3/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/spdk/dpdk/drivers/net/hns3/meson.build
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/dpdk/drivers/net/hns3/meson.build')
-rw-r--r--src/spdk/dpdk/drivers/net/hns3/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/spdk/dpdk/drivers/net/hns3/meson.build b/src/spdk/dpdk/drivers/net/hns3/meson.build
new file mode 100644
index 000000000..e01e6ce60
--- /dev/null
+++ b/src/spdk/dpdk/drivers/net/hns3/meson.build
@@ -0,0 +1,30 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018-2019 Hisilicon Limited
+
+if not is_linux
+ build = false
+ reason = 'only supported on Linux'
+ subdir_done()
+endif
+
+if arch_subdir != 'x86' and arch_subdir != 'arm' or not dpdk_conf.get('RTE_ARCH_64')
+ build = false
+ reason = 'only supported on x86_64 and arm64'
+ subdir_done()
+endif
+
+sources = files('hns3_cmd.c',
+ 'hns3_dcb.c',
+ 'hns3_intr.c',
+ 'hns3_ethdev.c',
+ 'hns3_ethdev_vf.c',
+ 'hns3_fdir.c',
+ 'hns3_flow.c',
+ 'hns3_mbx.c',
+ 'hns3_regs.c',
+ 'hns3_rss.c',
+ 'hns3_rxtx.c',
+ 'hns3_stats.c',
+ 'hns3_mp.c')
+
+deps += ['hash']