summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/drivers/net/szedata2/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/spdk/dpdk/drivers/net/szedata2/meson.build
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/dpdk/drivers/net/szedata2/meson.build')
-rw-r--r--src/spdk/dpdk/drivers/net/szedata2/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/spdk/dpdk/drivers/net/szedata2/meson.build b/src/spdk/dpdk/drivers/net/szedata2/meson.build
new file mode 100644
index 000000000..b53fcbc59
--- /dev/null
+++ b/src/spdk/dpdk/drivers/net/szedata2/meson.build
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Intel Corporation
+
+dep = dependency('libsze2', required: false)
+build = dep.found()
+reason = 'missing dependency, "libsze2"'
+ext_deps += dep
+sources = files('rte_eth_szedata2.c')