summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/examples/performance-thread/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/spdk/dpdk/examples/performance-thread/Makefile
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/dpdk/examples/performance-thread/Makefile')
-rw-r--r--src/spdk/dpdk/examples/performance-thread/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/spdk/dpdk/examples/performance-thread/Makefile b/src/spdk/dpdk/examples/performance-thread/Makefile
new file mode 100644
index 000000000..08158914c
--- /dev/null
+++ b/src/spdk/dpdk/examples/performance-thread/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2015 Intel Corporation
+
+ifeq ($(RTE_SDK),)
+$(error "Please define RTE_SDK environment variable")
+endif
+
+# Default target, detect a build directory, by looking for a path with a .config
+RTE_TARGET ?= $(notdir $(abspath $(dir $(firstword $(wildcard $(RTE_SDK)/*/.config)))))
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+ifeq ($(filter y,$(CONFIG_RTE_ARCH_X86_64) $(CONFIG_RTE_ARCH_ARM64)),)
+$(error This application is only supported for x86_64 and arm64 targets)
+endif
+
+DIRS-y += l3fwd-thread
+DIRS-y += pthread_shim
+
+
+include $(RTE_SDK)/mk/rte.extsubdir.mk