summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/lib/librte_bpf/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/spdk/dpdk/lib/librte_bpf/meson.build
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/dpdk/lib/librte_bpf/meson.build')
-rw-r--r--src/spdk/dpdk/lib/librte_bpf/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/spdk/dpdk/lib/librte_bpf/meson.build b/src/spdk/dpdk/lib/librte_bpf/meson.build
new file mode 100644
index 000000000..55d7a1560
--- /dev/null
+++ b/src/spdk/dpdk/lib/librte_bpf/meson.build
@@ -0,0 +1,29 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Intel Corporation
+
+sources = files('bpf.c',
+ 'bpf_exec.c',
+ 'bpf_load.c',
+ 'bpf_pkt.c',
+ 'bpf_validate.c')
+
+if arch_subdir == 'x86' and dpdk_conf.get('RTE_ARCH_64')
+ sources += files('bpf_jit_x86.c')
+elif dpdk_conf.has('RTE_ARCH_ARM64')
+ sources += files('bpf_jit_arm64.c')
+endif
+
+install_headers('bpf_def.h',
+ 'rte_bpf.h',
+ 'rte_bpf_ethdev.h')
+
+deps += ['mbuf', 'net', 'ethdev']
+
+dep = dependency('libelf', required: false)
+if dep.found()
+ dpdk_conf.set('RTE_LIBRTE_BPF_ELF', 1)
+ sources += files('bpf_load_elf.c')
+ ext_deps += dep
+endif
+build = false
+reason = 'not needed by SPDK'