summaryrefslogtreecommitdiffstats
path: root/src/xxHash/cmake_unofficial
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/xxHash/cmake_unofficial
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/xxHash/cmake_unofficial')
-rw-r--r--src/xxHash/cmake_unofficial/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/xxHash/cmake_unofficial/CMakeLists.txt b/src/xxHash/cmake_unofficial/CMakeLists.txt
new file mode 100644
index 000000000..825193e12
--- /dev/null
+++ b/src/xxHash/cmake_unofficial/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required(VERSION 2.6)
+cmake_policy(VERSION 2.6)
+
+project(xxhash)
+
+set(XXHASH_LIB_VERSION "0.42.0")
+set(XXHASH_LIB_SOVERSION "0")
+
+add_library(xxhash SHARED ../xxhash.c)
+set_target_properties(xxhash PROPERTIES COMPILE_DEFINITIONS "XXHASH_EXPORT"
+ VERSION "${XXHASH_LIB_VERSION}"
+ SOVERSION "${XXHASH_LIB_SOVERSION}")
+set(install_libs xxhash)
+
+set(BUILD_STATIC_LIBS ON CACHE BOOL "Set to ON to build static libraries")
+if(BUILD_STATIC_LIBS)
+ add_library(xxhashstatic ../xxhash.c)
+ set_target_properties(xxhashstatic PROPERTIES OUTPUT_NAME xxhash)
+ LIST(APPEND install_libs xxhashstatic)
+endif(BUILD_STATIC_LIBS)
+
+
+INSTALL(FILES ../xxhash.h DESTINATION include)
+INSTALL(TARGETS ${install_libs} DESTINATION lib)