summaryrefslogtreecommitdiffstats
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /systemd/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
new file mode 100644
index 000000000..ad75ce61c
--- /dev/null
+++ b/systemd/CMakeLists.txt
@@ -0,0 +1,48 @@
+find_package(PkgConfig QUIET REQUIRED)
+pkg_get_variable(SYSTEMD_SYSTEM_UNIT_DIR "systemd" "systemd_system_unit_dir")
+if(NOT SYSTEMD_SYSTEM_UNIT_DIR)
+ pkg_get_variable(SYSTEMD_SYSTEM_UNIT_DIR "systemd" "systemdsystemunitdir")
+ if(NOT SYSTEMD_SYSTEM_UNIT_DIR)
+ set(SYSTEMD_SYSTEM_UNIT_DIR "${CMAKE_INSTALL_LIBDIR}/systemd/system")
+ endif()
+endif()
+set(SYSTEMD_SYSTEM_UNIT_DIR "${SYSTEMD_SYSTEM_UNIT_DIR}"
+ CACHE PATH "Location for systemd system unit files")
+
+set(CEPH_SYSTEMD_ENV_DIR "/etc/sysconfig"
+ CACHE PATH "Location for systemd service environmental variable settings files")
+set(SYSTEMD_ENV_FILE "${CEPH_SYSTEMD_ENV_DIR}/ceph")
+foreach(service
+ ceph-crash
+ ceph-fuse@
+ ceph-mds@
+ ceph-mgr@
+ ceph-mon@
+ ceph-osd@
+ ceph-radosgw@
+ ceph-rbd-mirror@
+ ceph-immutable-object-cache@
+ cephfs-mirror@
+ rbdmap)
+ configure_file(
+ ${service}.service.in
+ ${service}.service
+ @ONLY)
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${service}.service
+ DESTINATION ${SYSTEMD_SYSTEM_UNIT_DIR})
+endforeach()
+
+install(FILES
+ ceph.target
+ ceph-fuse.target
+ ceph-osd.target
+ ceph-mgr.target
+ ceph-mon.target
+ ceph-mds.target
+ ceph-radosgw.target
+ ceph-rbd-mirror.target
+ ceph-immutable-object-cache.target
+ ceph-volume@.service
+ cephfs-mirror.target
+ DESTINATION ${SYSTEMD_SYSTEM_UNIT_DIR})