summaryrefslogtreecommitdiffstats
path: root/src/java/native/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/java/native/CMakeLists.txt')
-rw-r--r--src/java/native/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/java/native/CMakeLists.txt b/src/java/native/CMakeLists.txt
new file mode 100644
index 000000000..2c6067b60
--- /dev/null
+++ b/src/java/native/CMakeLists.txt
@@ -0,0 +1,14 @@
+add_library(cephfs_jni SHARED
+ libcephfs_jni.cc
+ ScopedLocalRef.h
+ JniConstants.cpp
+ JniConstants.h)
+set_target_properties(cephfs_jni PROPERTIES
+ VERSION 1.0.0
+ SOVERSION 1)
+add_dependencies(cephfs_jni jni-header)
+include_directories(${JNI_INCLUDE_DIRS} ${CMAKE_CURRENT_BINARY_DIR})
+target_link_libraries(cephfs_jni PRIVATE cephfs ceph-common
+ ${EXTRALIBS} ${JNI_LIBRARIES})
+install(TARGETS cephfs_jni
+ DESTINATION ${CMAKE_INSTALL_LIBDIR})