summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/crypto/ccp/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/drivers/crypto/ccp/meson.build')
-rw-r--r--src/seastar/dpdk/drivers/crypto/ccp/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/crypto/ccp/meson.build b/src/seastar/dpdk/drivers/crypto/ccp/meson.build
new file mode 100644
index 000000000..071ccc5e7
--- /dev/null
+++ b/src/seastar/dpdk/drivers/crypto/ccp/meson.build
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Advanced Micro Devices, Inc. All rights reserved.
+
+if not is_linux
+ build = false
+endif
+dep = dependency('libcrypto', required: false)
+if not dep.found()
+ build = false
+endif
+deps += 'bus_vdev'
+deps += 'bus_pci'
+
+sources = files('rte_ccp_pmd.c',
+ 'ccp_crypto.c',
+ 'ccp_dev.c',
+ 'ccp_pci.c',
+ 'ccp_pmd_ops.c')
+
+ext_deps += dep