summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/crypto/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/drivers/crypto/meson.build')
-rw-r--r--src/seastar/dpdk/drivers/crypto/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/crypto/meson.build b/src/seastar/dpdk/drivers/crypto/meson.build
new file mode 100644
index 000000000..83e78860e
--- /dev/null
+++ b/src/seastar/dpdk/drivers/crypto/meson.build
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+drivers = ['aesni_gcm', 'aesni_mb', 'caam_jr', 'ccp', 'dpaa_sec', 'dpaa2_sec',
+ 'kasumi', 'mvsam', 'null', 'octeontx', 'openssl', 'qat', 'scheduler',
+ 'snow3g', 'virtio', 'zuc']
+
+std_deps = ['cryptodev'] # cryptodev pulls in all other needed deps
+config_flag_fmt = 'RTE_LIBRTE_@0@_PMD'
+driver_name_fmt = 'rte_pmd_@0@'