summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/examples/ethtool/ethtool-app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/examples/ethtool/ethtool-app/Makefile')
-rw-r--r--src/seastar/dpdk/examples/ethtool/ethtool-app/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/seastar/dpdk/examples/ethtool/ethtool-app/Makefile b/src/seastar/dpdk/examples/ethtool/ethtool-app/Makefile
new file mode 100644
index 000000000..3543bdee0
--- /dev/null
+++ b/src/seastar/dpdk/examples/ethtool/ethtool-app/Makefile
@@ -0,0 +1,31 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+ifeq ($(RTE_SDK),)
+$(error "Please define RTE_SDK environment variable")
+endif
+
+# Default target, detect a build directory, by looking for a path with a .config
+RTE_TARGET ?= $(notdir $(abspath $(dir $(firstword $(wildcard $(RTE_SDK)/*/.config)))))
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+# binary name
+APP = ethtool
+
+# all source are stored in SRCS-y
+SRCS-y := main.c ethapp.c
+
+CFLAGS += -O3 -pthread -I$(SRCDIR)/../lib
+CFLAGS += $(WERROR_FLAGS)
+
+LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
+LDLIBS += -lrte_ethtool
+
+ifeq ($(CONFIG_RTE_BUILD_SHARED_LIB),y)
+ifeq ($(CONFIG_RTE_LIBRTE_IXGBE_PMD),y)
+LDLIBS += -lrte_pmd_ixgbe
+endif
+endif
+
+include $(RTE_SDK)/mk/rte.extapp.mk