summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/app/test-acl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/app/test-acl/Makefile')
-rw-r--r--src/spdk/dpdk/app/test-acl/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/spdk/dpdk/app/test-acl/Makefile b/src/spdk/dpdk/app/test-acl/Makefile
new file mode 100644
index 000000000..5f26294cf
--- /dev/null
+++ b/src/spdk/dpdk/app/test-acl/Makefile
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+ifeq ($(CONFIG_RTE_LIBRTE_ACL),y)
+
+APP = testacl
+
+CFLAGS += $(WERROR_FLAGS)
+
+# all source are stored in SRCS-y
+SRCS-y := main.c
+
+include $(RTE_SDK)/mk/rte.app.mk
+
+endif