summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/drivers/event/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/drivers/event/Makefile')
-rw-r--r--src/spdk/dpdk/drivers/event/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/spdk/dpdk/drivers/event/Makefile b/src/spdk/dpdk/drivers/event/Makefile
new file mode 100644
index 000000000..86be41b9e
--- /dev/null
+++ b/src/spdk/dpdk/drivers/event/Makefile
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2016 Cavium, Inc
+#
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+DIRS-$(CONFIG_RTE_LIBRTE_PMD_SKELETON_EVENTDEV) += skeleton
+DIRS-$(CONFIG_RTE_LIBRTE_PMD_SW_EVENTDEV) += sw
+DIRS-$(CONFIG_RTE_LIBRTE_PMD_DSW_EVENTDEV) += dsw
+DIRS-$(CONFIG_RTE_LIBRTE_PMD_OCTEONTX_SSOVF) += octeontx
+DIRS-$(CONFIG_RTE_LIBRTE_PMD_OCTEONTX2_EVENTDEV) += octeontx2
+ifeq ($(CONFIG_RTE_LIBRTE_DPAA_BUS),y)
+DIRS-$(CONFIG_RTE_LIBRTE_PMD_DPAA_EVENTDEV) += dpaa
+endif
+ifeq ($(CONFIG_RTE_EAL_VFIO)$(CONFIG_RTE_LIBRTE_FSLMC_BUS),yy)
+DIRS-$(CONFIG_RTE_LIBRTE_PMD_DPAA2_EVENTDEV) += dpaa2
+endif
+DIRS-$(CONFIG_RTE_LIBRTE_PMD_OPDL_EVENTDEV) += opdl
+
+include $(RTE_SDK)/mk/rte.subdir.mk