summaryrefslogtreecommitdiffstats
path: root/config.h.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 14:53:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 14:53:22 +0000
commit52c021ee0b0c6ad2128ed550c694aad0d11d4c3f (patch)
tree83cf8627b94336cf4bee7479b9749263bbfd3a06 /config.h.in
parentInitial commit. (diff)
downloadisc-kea-52c021ee0b0c6ad2128ed550c694aad0d11d4c3f.tar.xz
isc-kea-52c021ee0b0c6ad2128ed550c694aad0d11d4c3f.zip
Adding upstream version 2.5.7.upstream/2.5.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'config.h.in')
-rw-r--r--config.h.in290
1 files changed, 290 insertions, 0 deletions
diff --git a/config.h.in b/config.h.in
new file mode 100644
index 0000000..88bced1
--- /dev/null
+++ b/config.h.in
@@ -0,0 +1,290 @@
+/* config.h.in. Generated from configure.ac by autoheader. */
+
+/* Define to 1 if system and steady clocks use the same duration type */
+#undef CHRONO_SAME_DURATION
+
+/* config.h inclusion marker */
+#undef CONFIG_H_WAS_INCLUDED
+
+/* AFL fuzzing was enabled. */
+#undef ENABLE_AFL
+
+/* Enable low-performing debugging facilities? */
+#undef ENABLE_DEBUG
+
+/* Check logger messages? */
+#undef ENABLE_LOGGER_CHECKS
+
+/* Does this platform have some undefined pthreads behavior? */
+#undef HAS_UNDEFINED_PTHREAD_BEHAVIOR
+
+/* Define to 1 if you have the <boost/asio/coroutine.hpp> header file. */
+#undef HAVE_BOOST_ASIO_COROUTINE_HPP
+
+/* Define to 1 if you have the <boost/asio.hpp> header file. */
+#undef HAVE_BOOST_ASIO_HPP
+
+/* Define to 1 if you have the <boost/asio/ip/address.hpp> header file. */
+#undef HAVE_BOOST_ASIO_IP_ADDRESS_HPP
+
+/* Define to 1 if you have the <boost/asio/signal_set.hpp> header file. */
+#undef HAVE_BOOST_ASIO_SIGNAL_SET_HPP
+
+/* Define to 1 if you have the <boost/asio/ssl.hpp> header file. */
+#undef HAVE_BOOST_ASIO_SSL_HPP
+
+/* Define to 1 if you have the <boost/atomic.hpp> header file. */
+#undef HAVE_BOOST_ATOMIC_HPP
+
+/* Define to 1 if you have the <boost/circular_buffer.hpp> header file. */
+#undef HAVE_BOOST_CIRCULAR_BUFFER_HPP
+
+/* Define to 1 if you have the
+ <boost/date_time/posix_time/posix_time_types.hpp> header file. */
+#undef HAVE_BOOST_DATE_TIME_POSIX_TIME_POSIX_TIME_TYPES_HPP
+
+/* Define to 1 if you have the <boost/foreach.hpp> header file. */
+#undef HAVE_BOOST_FOREACH_HPP
+
+/* Define to 1 if you have the <boost/functional/hash.hpp> header file. */
+#undef HAVE_BOOST_FUNCTIONAL_HASH_HPP
+
+/* Define to 1 if you have the <boost/integer/common_factor.hpp> header file.
+ */
+#undef HAVE_BOOST_INTEGER_COMMON_FACTOR_HPP
+
+/* Define to 1 if you have the
+ <boost/interprocess/sync/interprocess_upgradable_mutex.hpp> header file. */
+#undef HAVE_BOOST_INTERPROCESS_SYNC_INTERPROCESS_UPGRADABLE_MUTEX_HPP
+
+/* Define to 1 if you have the <boost/shared_ptr.hpp> header file. */
+#undef HAVE_BOOST_SHARED_PTR_HPP
+
+/* Define to 1 if you have the <boost/system/error_code.hpp> header file. */
+#undef HAVE_BOOST_SYSTEM_ERROR_CODE_HPP
+
+/* Define to 1 if you have the <botan/asio_stream.h> header file. */
+#undef HAVE_BOTAN_ASIO_STREAM_H
+
+/* Define to 1 if you have the <botan/botan.h> header file. */
+#undef HAVE_BOTAN_BOTAN_H
+
+/* Define to 1 if getsockopt(IPV6_USE_MIN_MTU) does not work */
+#undef HAVE_BROKEN_GET_IPV6_USE_MIN_MTU
+
+/* Define to 1 if gtest defines edit_distance::CreateUnifiedDiff */
+#undef HAVE_CREATE_UNIFIED_DIFF
+
+/* Define to 1 if you have the <dlfcn.h> header file. */
+#undef HAVE_DLFCN_H
+
+/* Define to 1 if you have the `EVP_MD_CTX_create' function. */
+#undef HAVE_EVP_MD_CTX_CREATE
+
+/* Define to 1 if you have the `EVP_MD_CTX_destroy' function. */
+#undef HAVE_EVP_MD_CTX_DESTROY
+
+/* Define to 1 if you have the `EVP_MD_CTX_free' function. */
+#undef HAVE_EVP_MD_CTX_FREE
+
+/* Define to 1 if you have the `EVP_MD_CTX_new' function. */
+#undef HAVE_EVP_MD_CTX_NEW
+
+/* Define to 1 if you have the `EVP_PKEY_new_mac_key' function. */
+#undef HAVE_EVP_PKEY_NEW_MAC_KEY
+
+/* Define to 1 if you have the `EVP_PKEY_new_raw_private_key' function. */
+#undef HAVE_EVP_PKEY_NEW_RAW_PRIVATE_KEY
+
+/* Define to 1 if boost::asio::ssl::context::tls is available */
+#undef HAVE_GENERIC_TLS_METHOD
+
+/* Define to 1 if you have the <gssapi/gssapi.h> header file. */
+#undef HAVE_GSSAPI_GSSAPI_H
+
+/* Define to 1 if you have the <gssapi/gssapi_krb5.h> header file. */
+#undef HAVE_GSSAPI_GSSAPI_KRB5_H
+
+/* gss_str_to_oid is available */
+#undef HAVE_GSS_STR_TO_OID
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#undef HAVE_INTTYPES_H
+
+/* Define to 1 if std::is_base_of is available */
+#undef HAVE_IS_BASE_OF
+
+/* Define to 1 if you have the <krb5.h> header file. */
+#undef HAVE_KRB5_H
+
+/* Define to 1 if you have the <krb5/krb5.h> header file. */
+#undef HAVE_KRB5_KRB5_H
+
+/* Define to 1 if you have the <log4cplus/logger.h> header file. */
+#undef HAVE_LOG4CPLUS_LOGGER_H
+
+/* MySQL is present */
+#undef HAVE_MYSQL
+
+/* MySQL has mysql_get_option defined. */
+#undef HAVE_MYSQL_GET_OPTION
+
+/* MySQL uses my_bool */
+#undef HAVE_MYSQL_MY_BOOL
+
+/* NETCONF capabilities enabled */
+#undef HAVE_NETCONF
+
+/* Check for optreset? */
+#undef HAVE_OPTRESET
+
+/* PostgreSQL is present */
+#undef HAVE_PGSQL
+
+/* PostgreSQL was built with OpenSSL support */
+#undef HAVE_PGSQL_SSL
+
+/* PostgreSQL connection parameter tcp_user_timeout supported */
+#undef HAVE_PGSQL_TCP_USER_TIMEOUT
+
+/* Define to 1 if you have the `pselect' function. */
+#undef HAVE_PSELECT
+
+/* Define to 1 if sockaddr has a sa_len member, and corresponding sin_len and
+ sun_len */
+#undef HAVE_SA_LEN
+
+/* Define to 1 if stdbool.h conforms to C99. */
+#undef HAVE_STDBOOL_H
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#undef HAVE_STDINT_H
+
+/* Define to 1 if you have the <stdio.h> header file. */
+#undef HAVE_STDIO_H
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#undef HAVE_STDLIB_H
+
+/* Define to 1 if boost::asio::ssl::error::stream_truncated is available */
+#undef HAVE_STREAM_TRUNCATED_ERROR
+
+/* Define to 1 if you have the <strings.h> header file. */
+#undef HAVE_STRINGS_H
+
+/* Define to 1 if you have the <string.h> header file. */
+#undef HAVE_STRING_H
+
+/* Define to 1 if you have the <sys/devpoll.h> header file. */
+#undef HAVE_SYS_DEVPOLL_H
+
+/* Define to 1 if you have the <sys/filio.h> header file. */
+#undef HAVE_SYS_FILIO_H
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#undef HAVE_SYS_STAT_H
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#undef HAVE_SYS_TYPES_H
+
+/* Define to 1 if boost::asio::ssl::context::tlsv12 is available */
+#undef HAVE_TLS_1_2_METHOD
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#undef HAVE_UNISTD_H
+
+/* Define to 1 if you have the <utils/errcodes.h> header file. */
+#undef HAVE_UTILS_ERRCODES_H
+
+/* Check valgrind headers */
+#undef HAVE_VALGRIND_HEADERS
+
+/* Define to 1 if you have the <valgrind/valgrind.h> header file. */
+#undef HAVE_VALGRIND_VALGRIND_H
+
+/* Define to 1 if the system has the type `_Bool'. */
+#undef HAVE__BOOL
+
+/* Define to 1 if libc is musl */
+#undef LIBC_MUSL
+
+/* Explicit initialization of log4cplus possible */
+#undef LOG4CPLUS_INITIALIZER_H
+
+/* Define to the sub-directory where libtool stores uninstalled libraries. */
+#undef LT_OBJDIR
+
+/* Running on BSD? */
+#undef OS_BSD
+
+/* Running on FreeBSD? */
+#undef OS_FREEBSD
+
+/* Running on Linux? */
+#undef OS_LINUX
+
+/* Running on NetBSD? */
+#undef OS_NETBSD
+
+/* Running on OpenBSD? */
+#undef OS_OPENBSD
+
+/* Running on OSX? */
+#undef OS_OSX
+
+/* Running on Solaris? */
+#undef OS_SOLARIS
+
+/* Name of package */
+#undef PACKAGE
+
+/* Define to the address where bug reports for this package should be sent. */
+#undef PACKAGE_BUGREPORT
+
+/* Define to the full name of this package. */
+#undef PACKAGE_NAME
+
+/* Define to the full name and version of this package. */
+#undef PACKAGE_STRING
+
+/* Define to the one symbol short name of this package. */
+#undef PACKAGE_TARNAME
+
+/* Define to the home page for this package. */
+#undef PACKAGE_URL
+
+/* Define to the version of this package. */
+#undef PACKAGE_VERSION
+
+/* Define to 1 if all of the C90 standard headers exist (not just the ones
+ required in a freestanding environment). This macro is provided for
+ backward compatibility; new code need not use it. */
+#undef STDC_HEADERS
+
+/* Was Kea statically linked? */
+#undef USE_STATIC_LINK
+
+/* Version number of package */
+#undef VERSION
+
+/* Compile with Botan crypto */
+#undef WITH_BOTAN
+
+/* Define to 1 if Botan boost TLS is available */
+#undef WITH_BOTAN_BOOST
+
+/* Heimdal GSS-API implementation */
+#undef WITH_HEIMDAL
+
+/* Compile with OpenSSL crypto */
+#undef WITH_OPENSSL
+
+/* Define to 1 if `lex' declares `yytext' as a `char *' by default, not a
+ `char[]'. */
+#undef YYTEXT_POINTER
+
+/* Define to `unsigned int' if <sys/types.h> does not define. */
+#undef size_t
+
+/* Define to `int' if <sys/types.h> does not define. */
+#undef ssize_t