summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 06:24:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 06:24:58 +0000
commitba233a0cbad76b4783a03893e7bf4716fbc0f0ec (patch)
treead369728c1edbe3631c8150585659078ae5d7d0b /.pre-commit-config.yaml
parentReleasing progress-linux version 6.17.2-3~progress7.99u1. (diff)
downloadansible-lint-ba233a0cbad76b4783a03893e7bf4716fbc0f0ec.tar.xz
ansible-lint-ba233a0cbad76b4783a03893e7bf4716fbc0f0ec.zip
Merging upstream version 24.6.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml79
1 files changed, 45 insertions, 34 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 1174880..fa6297f 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -14,7 +14,8 @@ ci:
submodules: true
exclude: >
(?x)^(
- .config/requirements.*|
+ .config/constraints.txt|
+ .config/.*requirements.*|
.vscode/extensions.json|
.vscode/settings.json|
examples/broken/encoding.yml|
@@ -32,9 +33,14 @@ repos:
- repo: meta
hooks:
- id: check-useless-excludes
+ # https://github.com/pappasam/toml-sort/issues/69
+ # - repo: https://github.com/pappasam/toml-sort
+ # rev: v0.23.1
+ # hooks:
+ # - id: toml-sort-fix
- repo: https://github.com/pre-commit/mirrors-prettier
# keep it before yamllint
- rev: v3.0.0-alpha.9-for-vscode
+ rev: v4.0.0-alpha.8
hooks:
- id: prettier
# Temporary excludes so we can gradually normalize the formatting
@@ -44,6 +50,7 @@ repos:
examples/other/some.j2.yaml|
examples/playbooks/collections/.*|
examples/playbooks/example.yml|
+ examples/playbooks/invalid-transform.yml|
examples/playbooks/multiline-brackets.*|
examples/playbooks/templates/not-valid.yaml|
examples/playbooks/vars/empty.transformed.yml|
@@ -59,22 +66,22 @@ repos:
)$
always_run: true
additional_dependencies:
- - prettier
- - prettier-plugin-toml
- - prettier-plugin-sort-json
+ - prettier@3.2.4
+ - prettier-plugin-toml@2.0.1
+ - prettier-plugin-sort-json@3.1.0
- repo: https://github.com/streetsidesoftware/cspell-cli
- rev: v6.31.0
+ rev: v8.8.2
hooks:
- id: cspell
# entry: codespell --relative
args: [--relative, --no-progress, --no-summary]
name: Spell check with cspell
- repo: https://github.com/python-jsonschema/check-jsonschema
- rev: 0.23.2
+ rev: 0.28.4
hooks:
- id: check-github-workflows
- repo: https://github.com/pre-commit/pre-commit-hooks.git
- rev: v4.4.0
+ rev: v4.6.0
hooks:
- id: end-of-file-fixer
# ignore formatting-prettier to have an accurate prettier comparison
@@ -101,7 +108,7 @@ repos:
- id: debug-statements
language_version: python3
- repo: https://github.com/codespell-project/codespell
- rev: v2.2.5
+ rev: v2.3.0
hooks:
- id: codespell
exclude: >
@@ -115,7 +122,7 @@ repos:
additional_dependencies:
- tomli
- repo: https://github.com/adrienverge/yamllint.git
- rev: v1.32.0
+ rev: v1.35.1
hooks:
- id: yamllint
exclude: >
@@ -129,79 +136,83 @@ repos:
files: \.(yaml|yml)$
types: [file, yaml]
entry: yamllint --strict
- - repo: https://github.com/charliermarsh/ruff-pre-commit
- rev: "v0.0.274"
+ - repo: https://github.com/astral-sh/ruff-pre-commit
+ rev: "v0.4.7"
hooks:
- id: ruff
args: [--fix, --exit-non-zero-on-fix]
- repo: https://github.com/psf/black
- rev: 23.3.0
+ rev: 24.4.2
hooks:
- id: black
language_version: python3
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v1.4.0
+ rev: v1.10.0
hooks:
- id: mypy
# empty args needed in order to match mypy cli behavior
args: [--strict]
additional_dependencies:
- - ansible-compat>=4.1.2
+ - ansible-compat>=24.5.1
- black>=22.10.0
- cryptography>=39.0.1
- filelock>=3.12.2
+ - importlib_metadata
- jinja2
+ - license-expression >= 30.3.0
- pytest-mock
- pytest>=7.2.2
- rich>=13.2.0
- - ruamel-yaml>=0.17.31
- - ruamel-yaml-clib>=0.2.7
- - spdx-tools>=0.7.1
+ - ruamel-yaml-clib>=0.2.8
+ - ruamel-yaml>=0.18.6
- subprocess-tee
- types-PyYAML
- - types-jsonschema>=4.4.2
+ - types-jsonschema>=4.20.0.0
- types-pkg_resources
- types-setuptools
- wcmatch
exclude: >
(?x)^(
+ collections/.*|
test/local-content/.*|
plugins/.*
)$
- repo: https://github.com/pycqa/pylint
- rev: v3.0.0a6
+ rev: v3.2.2
hooks:
- id: pylint
args:
- --output-format=colorized
additional_dependencies:
- - ansible-compat>=4.1.2
+ - ansible-compat>=24.5.1
- ansible-core>=2.14.0
- black>=22.10.0
- docutils
- filelock>=3.12.2
- - jsonschema>=4.9.0
+ - importlib_metadata
+ - jsonschema>=4.20.0
+ - license-expression >= 30.3.0
- pytest-mock
- pytest>=7.2.2
- pyyaml
- rich>=13.2.0
- - ruamel-yaml>=0.17.31
- ruamel-yaml-clib>=0.2.7
- - spdx-tools>=0.7.1
+ - ruamel-yaml>=0.18.2
+ - setuptools # needed for pkg_resources import
- typing_extensions
- wcmatch
- yamllint
- repo: https://github.com/jazzband/pip-tools
- rev: 6.13.0
+ rev: 7.4.1
hooks:
- id: pip-compile
name: lock
alias: lock
always_run: true
- entry: pip-compile --upgrade --resolver=backtracking -q --no-annotate --output-file=.config/requirements-lock.txt pyproject.toml --strip-extras --unsafe-package ruamel-yaml-clib --unsafe-package resolvelib
- files: ^.config\/requirements.*$
+ entry: pip-compile --upgrade --no-annotate --output-file=.config/requirements-lock.txt pyproject.toml --strip-extras --unsafe-package ruamel-yaml-clib --unsafe-package resolvelib
+ files: ^.config\/.*requirements.*$
language: python
- language_version: "3.9" # minimal we support officially
+ language_version: "3.10" # minimal we support officially
pass_filenames: false
stages: [manual]
additional_dependencies:
@@ -210,22 +221,22 @@ repos:
name: deps
alias: deps
always_run: true
- entry: pip-compile --resolver=backtracking -q --no-annotate --output-file=.config/requirements.txt pyproject.toml --extra docs --extra test --strip-extras --unsafe-package ruamel-yaml-clib --unsafe-package resolvelib
- files: ^.config\/requirements.*$
+ entry: pip-compile --no-annotate --output-file=.config/constraints.txt pyproject.toml --all-extras --strip-extras --unsafe-package wcmatch --unsafe-package ruamel-yaml-clib --unsafe-package resolvelib
+ files: ^.config\/.*requirements.*$
language: python
- language_version: "3.9" # minimal we support officially
+ language_version: "3.10" # minimal we support officially
pass_filenames: false
additional_dependencies:
- pip>=22.3.1
- id: pip-compile
- entry: pip-compile --resolver=backtracking -q --no-annotate --output-file=.config/requirements.txt pyproject.toml --extra docs --extra test --strip-extras --unsafe-package ruamel-yaml-clib --unsafe-package resolvelib --upgrade
+ entry: pip-compile -v --no-annotate --output-file=.config/constraints.txt pyproject.toml --all-extras --strip-extras --unsafe-package wcmatch --unsafe-package ruamel-yaml-clib --unsafe-package resolvelib --upgrade
language: python
always_run: true
pass_filenames: false
- files: ^.config\/requirements.*$
+ files: ^.config\/.*requirements.*$
alias: up
stages: [manual]
- language_version: "3.9" # minimal we support officially
+ language_version: "3.10" # minimal we support officially
additional_dependencies:
- pip>=22.3.1
- # keep at bottom as these are slower