summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:21:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:21:25 +0000
commitaf4c903a50d478ec572d4295e5ee0432d868a9e8 (patch)
tree154cfc87ab3c504c4a3db007a274b6e9d1a07594 /debian/rules
parentReleasing progress-linux version 6.17.2-2~progress7.99u1. (diff)
downloadansible-lint-af4c903a50d478ec572d4295e5ee0432d868a9e8.tar.xz
ansible-lint-af4c903a50d478ec572d4295e5ee0432d868a9e8.zip
Merging debian version 6.17.2-3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index b0f80a6..6cf51fc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,7 @@ export LC_ALL=C.UTF-8
export PYBUILD_BEFORE_TEST=cp --recursive {dir}/examples {dir}/conftest.py {dir}/.pre-commit-config.yaml {dir}/.ansible-lint {build_dir}/
export PYBUILD_AFTER_TEST=rm -Rf {build_dir}/examples {build_dir}/conftest.py {build_dir}/.pre-commit-config.yaml {build_dir}/.ansible-lint
-export PYBUILD_TEST_ARGS=-n auto -k "not (test_spdx or test_args_module_pass or test_risky_file_permissions or test_fqcn_builtin_fail or test_fqcn_builtin_pass or test_transformer or test_call_from_outside_venv or test_schema_moves or test_rules_id_format or test_yamllint or test_example or test_example_custom_module or test_verbosity or test_task_hook_import_playbook)"
+export PYBUILD_TEST_ARGS=-n auto -k "not (test_spdx or test_args_module_pass or test_risky_file_permissions or test_fqcn_builtin_fail or test_fqcn_builtin_pass or test_transformer or test_call_from_outside_venv or test_schema_moves or test_rules_id_format or test_yamllint or test_example or test_example_custom_module or test_verbosity or test_task_hook_import_playbook or test_request_timeouterror_handling or test_requests_uses_timeout or test_schema_refresh_cli or test_refresh_schemas)"
# test_spdx: requires the yet-to-be-packaged https://pypi.org/project/spdx/
# test_args_module_pass: require internet access
# test_risky_file_permissions: requires internet access
@@ -19,6 +19,10 @@ export PYBUILD_TEST_ARGS=-n auto -k "not (test_spdx or test_args_module_pass or
# test_example_custom_module: unknown
# test_verbosity: unknown
# test_task_hook_import_playbook: unknown
+# test_request_timeouterror_handling: not good for autopkgtest: requires a writable filesystem
+# test_requests_uses_timeout: works during the build, but not as an autopkgtest
+# test_schema_refresh_cli: works during the build, but not as an autopkgtest
+# test_refresh_schemas: works during the build, but not as an autopkgtest
%:
dh $@ --buildsystem=pybuild