summaryrefslogtreecommitdiffstats
path: root/tools/update-version.sh
diff options
context:
space:
mode:
Diffstat (limited to 'tools/update-version.sh')
-rwxr-xr-xtools/update-version.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/update-version.sh b/tools/update-version.sh
new file mode 100755
index 0000000..e2cd24d
--- /dev/null
+++ b/tools/update-version.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+DIR=$(dirname "$0")
+VERSION=$(./tools/get-version.sh)
+mkdir -p "${DIR}/../dist"
+sed -e "s/VERSION_PLACEHOLDER/${VERSION}/" \
+ "${DIR}/../.config/ansible-lint.spec" \
+ > "${DIR}/../dist/ansible-lint.spec"