summaryrefslogtreecommitdiffstats
path: root/ansible_collections/hetzner/hcloud/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-18 05:52:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-18 05:52:22 +0000
commit38b7c80217c4e72b1d8988eb1e60bb6e77334114 (patch)
tree356e9fd3762877d07cde52d21e77070aeff7e789 /ansible_collections/hetzner/hcloud/pyproject.toml
parentAdding upstream version 7.7.0+dfsg. (diff)
downloadansible-38b7c80217c4e72b1d8988eb1e60bb6e77334114.tar.xz
ansible-38b7c80217c4e72b1d8988eb1e60bb6e77334114.zip
Adding upstream version 9.4.0+dfsg.upstream/9.4.0+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ansible_collections/hetzner/hcloud/pyproject.toml')
-rw-r--r--ansible_collections/hetzner/hcloud/pyproject.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/ansible_collections/hetzner/hcloud/pyproject.toml b/ansible_collections/hetzner/hcloud/pyproject.toml
new file mode 100644
index 000000000..5263580cb
--- /dev/null
+++ b/ansible_collections/hetzner/hcloud/pyproject.toml
@@ -0,0 +1,28 @@
+[tool.black]
+line-length = 120
+
+[tool.isort]
+profile = "black"
+combine_as_imports = true
+add_imports = ["from __future__ import annotations"]
+
+[tool.pylint.main]
+py-version = "3.8"
+recursive = true
+jobs = 0
+
+max-line-length = 120
+ignore-paths = [
+ "plugins/module_utils/vendor",
+]
+
+[tool.pylint.reports]
+output-format = "colorized"
+
+[tool.pylint.basic]
+good-names = ["i", "j", "k", "ex", "_", "ip", "id"]
+
+[tool.pylint.messages_control]
+disable = [
+ "wrong-import-position",
+]