summaryrefslogtreecommitdiffstats
path: root/ansible_collections/kaytus/ksmanage/plugins/modules/backup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:34:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:34:10 +0000
commit83767dd892fb9c94d000c123a44f19e564d11b6e (patch)
tree0684bc85fdc395fc5aadaa5ad68ba3ec9d4a64a7 /ansible_collections/kaytus/ksmanage/plugins/modules/backup.py
parentReleasing progress-linux version 10.0.0+dfsg-1~progress7.99u1. (diff)
downloadansible-83767dd892fb9c94d000c123a44f19e564d11b6e.tar.xz
ansible-83767dd892fb9c94d000c123a44f19e564d11b6e.zip
Merging upstream version 10.0.1+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ansible_collections/kaytus/ksmanage/plugins/modules/backup.py')
-rw-r--r--ansible_collections/kaytus/ksmanage/plugins/modules/backup.py240
1 files changed, 120 insertions, 120 deletions
diff --git a/ansible_collections/kaytus/ksmanage/plugins/modules/backup.py b/ansible_collections/kaytus/ksmanage/plugins/modules/backup.py
index 13023d0ad..3f4a17856 100644
--- a/ansible_collections/kaytus/ksmanage/plugins/modules/backup.py
+++ b/ansible_collections/kaytus/ksmanage/plugins/modules/backup.py
@@ -1,120 +1,120 @@
-#!/usr/bin/python
-# -*- coding:utf-8 -*-
-
-# Copyright(C) 2023 Kaytus Inc. All Rights Reserved.
-# GNU General Public License v3.0+ (see COPYING or https://www.gnu.org/licenses/gpl-3.0.txt)
-
-from __future__ import (absolute_import, division, print_function)
-
-__metaclass__ = type
-
-DOCUMENTATION = '''
----
-module: backup
-version_added: "1.0.0"
-author:
- - WangBaoshan (@ieisystem)
-short_description: Backup server settings
-description:
- - Backup server settings on kaytus Server.
-notes:
- - Does not support C(check_mode).
-options:
- bak_file:
- description:
- - Backup file or bak folder.
- required: true
- type: str
- item:
- description:
- - Export item.
- - The values for M5 modules are 'all', 'network', 'service', 'ntp', 'snmptrap', 'dns', 'smtp', 'ad', 'ldap', 'user', 'bios'.
- - The values for M6 modules are 'all', 'network', 'service', 'ntp', 'snmptrap', 'kvm', 'ipmi', 'authentication', 'syslog'.
- - The values for M7 modules are 'all', 'network', 'service', 'syslog', 'ncsi'.
- choices: ['all', 'network', 'service', 'ntp', 'snmptrap', 'dns', 'smtp', 'ad', 'ldap',
- 'user', 'bios', 'kvm', 'ipmi', 'authentication', 'syslog', 'ncsi']
- required: true
- type: str
-extends_documentation_fragment:
- - kaytus.ksmanage.ksmanage
-'''
-
-EXAMPLES = '''
-- name: Backup test
- hosts: ksmanage
- connection: local
- gather_facts: false
- vars:
- ksmanage:
- host: "{{ ansible_ssh_host }}"
- username: "{{ username }}"
- password: "{{ password }}"
-
- tasks:
-
- - name: "Backup server settings"
- kaytus.ksmanage.backup:
- bak_file: "/home/wbs/"
- item: "all"
- provider: "{{ ksmanage }}"
-'''
-
-RETURN = '''
-message:
- description: Messages returned after module execution.
- returned: always
- type: str
-state:
- description: Status after module execution.
- returned: always
- type: str
-changed:
- description: Check to see if a change was made on the device.
- returned: always
- type: bool
-'''
-
-from ansible.module_utils.basic import AnsibleModule
-from ansible_collections.kaytus.ksmanage.plugins.module_utils.ksmanage import (ksmanage_argument_spec, get_connection)
-
-
-class Backup(object):
- def __init__(self, argument_spec):
- self.spec = argument_spec
- self.module = None
- self.init_module()
- self.results = dict()
-
- def init_module(self):
- """Init module object"""
-
- self.module = AnsibleModule(
- argument_spec=self.spec, supports_check_mode=False)
-
- def run_command(self):
- self.module.params['subcommand'] = 'backup'
- self.results = get_connection(self.module)
-
- def show_result(self):
- """Show result"""
- self.module.exit_json(**self.results)
-
- def work(self):
- """Worker"""
- self.run_command()
- self.show_result()
-
-
-def main():
- argument_spec = dict(
- bak_file=dict(type='str', required=True),
- item=dict(type='str', required=True, choices=['all', 'network', 'service', 'ntp', 'snmptrap', 'dns', 'smtp', 'ad',
- 'ldap', 'user', 'bios', 'kvm', 'ipmi', 'authentication', 'syslog', 'ncsi']),
- )
- argument_spec.update(ksmanage_argument_spec)
- backup_obj = Backup(argument_spec)
- backup_obj.work()
-
-
-if __name__ == '__main__':
- main()
+#!/usr/bin/python
+# -*- coding:utf-8 -*-
+
+# Copyright(C) 2023 Kaytus Inc. All Rights Reserved.
+# GNU General Public License v3.0+ (see COPYING or https://www.gnu.org/licenses/gpl-3.0.txt)
+
+from __future__ import (absolute_import, division, print_function)
+
+__metaclass__ = type
+
+DOCUMENTATION = '''
+---
+module: backup
+version_added: "1.0.0"
+author:
+ - WangBaoshan (@ieisystem)
+short_description: Backup server settings
+description:
+ - Backup server settings on kaytus Server.
+notes:
+ - Does not support C(check_mode).
+options:
+ bak_file:
+ description:
+ - Backup file or bak folder.
+ required: true
+ type: str
+ item:
+ description:
+ - Export item.
+ - The values for M5 modules are 'all', 'network', 'service', 'ntp', 'snmptrap', 'dns', 'smtp', 'ad', 'ldap', 'user', 'bios'.
+ - The values for M6 modules are 'all', 'network', 'service', 'ntp', 'snmptrap', 'kvm', 'ipmi', 'authentication', 'syslog'.
+ - The values for M7 modules are 'all', 'network', 'service', 'syslog', 'ncsi'.
+ choices: ['all', 'network', 'service', 'ntp', 'snmptrap', 'dns', 'smtp', 'ad', 'ldap',
+ 'user', 'bios', 'kvm', 'ipmi', 'authentication', 'syslog', 'ncsi']
+ required: true
+ type: str
+extends_documentation_fragment:
+ - kaytus.ksmanage.ksmanage
+'''
+
+EXAMPLES = '''
+- name: Backup test
+ hosts: ksmanage
+ connection: local
+ gather_facts: false
+ vars:
+ ksmanage:
+ host: "{{ ansible_ssh_host }}"
+ username: "{{ username }}"
+ password: "{{ password }}"
+
+ tasks:
+
+ - name: "Backup server settings"
+ kaytus.ksmanage.backup:
+ bak_file: "/home/wbs/"
+ item: "all"
+ provider: "{{ ksmanage }}"
+'''
+
+RETURN = '''
+message:
+ description: Messages returned after module execution.
+ returned: always
+ type: str
+state:
+ description: Status after module execution.
+ returned: always
+ type: str
+changed:
+ description: Check to see if a change was made on the device.
+ returned: always
+ type: bool
+'''
+
+from ansible.module_utils.basic import AnsibleModule
+from ansible_collections.kaytus.ksmanage.plugins.module_utils.ksmanage import (ksmanage_argument_spec, get_connection)
+
+
+class Backup(object):
+ def __init__(self, argument_spec):
+ self.spec = argument_spec
+ self.module = None
+ self.init_module()
+ self.results = dict()
+
+ def init_module(self):
+ """Init module object"""
+
+ self.module = AnsibleModule(
+ argument_spec=self.spec, supports_check_mode=False)
+
+ def run_command(self):
+ self.module.params['subcommand'] = 'backup'
+ self.results = get_connection(self.module)
+
+ def show_result(self):
+ """Show result"""
+ self.module.exit_json(**self.results)
+
+ def work(self):
+ """Worker"""
+ self.run_command()
+ self.show_result()
+
+
+def main():
+ argument_spec = dict(
+ bak_file=dict(type='str', required=True),
+ item=dict(type='str', required=True, choices=['all', 'network', 'service', 'ntp', 'snmptrap', 'dns', 'smtp', 'ad',
+ 'ldap', 'user', 'bios', 'kvm', 'ipmi', 'authentication', 'syslog', 'ncsi']),
+ )
+ argument_spec.update(ksmanage_argument_spec)
+ backup_obj = Backup(argument_spec)
+ backup_obj.work()
+
+
+if __name__ == '__main__':
+ main()